I use Arch Linux (Kernel: 4.17.2-1-ARCH) with Gnome 3.28.2. Along with Virtual Box I have installed the following packages:

virtualbox-host-modules-arch  5.2.12-10
virtualbox-guest-modules-arch  5.2.12-10
virtualbox-guest-utils  5.2.12-2
virtualbox-guest-iso  5.2.12-1

Using Virtual Box I have a guest with Windows 10 64 bit. I have installed the guest additions on the Windows 10 box.

The guest OS works fine, however, it supports only a small number of resolutions. Specifically the following:

Guest Available Resolutions

However my native resolutions is 1920x1080.

When using VirtualBox's menu View -> Virtual Screen 1 I can see all available resolutions (including 1920x1080), however, selecting them does nothing.

I have also tried the guide provided by the Arch Linux Wiki. Specifically, I have run the command:

VBoxManage setextradata "Windows10" "CustomVideoMode1" "1920x1080x32"

and

VBoxManage setextradata "Windows10" "Virtual Screen 1" "1920x1080x32"

Unfortunately, nothing happens.

Is this a bug or am I doing something wrong?

  • Is Win10 the guest os? Your link is for arch guest. – Biswapriyo Jun 26 at 17:38
  • @biswapriyo Arch is the host, Windows is the guest. Ok, my bad, that explains why this specific thing does not work. What about the rest thought? – Aventinus Jun 26 at 18:37
  • (1) Try to increase Visual RAM (VRAM) in the virtual machine by example VBoxManage modifyvm "Name of VM" --vram 1024, depending on your RAM amount. (2) In VirtualBox menu File > Preferences > Display, set “Maximum guest screen size” to “None” (link). – harrymc Jun 29 at 18:14
  • Output of VBoxManage getextradata global GUI/MaxGuestResolution ? – ssnobody Jun 29 at 21:42
  • @harrymc VBoxManage modifyvm "Name of VM" --vram 1024 outputs Invalid RAM size: 1024 MB (must be in range [0, 256] MB), even though the host has 16GB of RAM. Also, interestingly, there is no "VirtualBox menu File > Preferences > Display, set “Maximum guest screen size”" option in my version. Maybe this option has been removed in the latest versions of Virtual Box? – Aventinus Jun 30 at 10:21

Try this :

  • In the virtual machine's Settings > Display, uncheck "Enable 3D Acceleration" and see if this helps.

  • While the virtual machine is turned off, enter :

    VBoxManage modifyvm "Name of VM" --vram 256
    
  • While the virtual machine is turned off, in VirtualBox menu File > Preferences > Display, set "Maximum guest screen size" to "None" (link).

  • While the VM is running, enter on the host :

    VBoxManage controlvm "Name of VM" setvideomodehint 1920 1080 32
    

If nothing helps, try reinstalling VirtualBox.

  • I have unchecked 3D Acceleration. I ran VBoxManage modifyvm "Name of VM" --vram 256. There is Maximum guest screen size option. Definitely not as the link implies. Maybe is has been removed in the latest versions? I also VBoxManage controlvm "Name of VM" setvideomodehint 1920 1080 32. None of these things work. – Aventinus Jul 3 at 15:41
  • This is not normal. Have you installed the guest additions in the Windows 10 VM? They are not required on the host and can maybe be uninstalled. If everything fails, uninstall VirtualBox, clean up its folders and reinstall. – harrymc Jul 3 at 15:57
  • I have installed the Guest Additions in the Windows 10 VM, yes. I guess the only option is to reinstall and see how it goes. – Aventinus Jul 3 at 15:59
  • How is it going? – harrymc Jul 7 at 4:52

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.