1

I have a new surface book pro with Windows 10 Pro. On this machine alone I am unable to access my network shares. I have several other machines on my network that can access these shares without issues. Some shares allow anonymous access, others require credentials.

My shares are all on a synology rackstation.

When I attempt to access my shares via UNC in explorer I receive an

unspecified error

Attempting to create a mapped drive via CMD shows error.

System error 58 has occurred. The specified server cannot perform the requested operation.

I can ping the rackstation, access it via the web portal and it even shows up in explorer under 'media devices' (but not under 'computers')

basic steps already taken:

  • tried another wireless network here
  • tried with firewalls disabled
  • No AV installed (only windows defender)
  • Reset TCP stack
  • IP only, rather than DNS UNC

Checked the following services are running:

  • Computer Browser
  • DHCP Client
  • DNS Client
  • Function Discovery Resource Publication
  • Server
  • SSDP Discovery
  • TCP/IP Netbios helper UPnP Device Host
  • Workstation

There are a number of servers / computers on my home network. I'd expect to be able to see them all in Explorer under 'Network' but only two show up. the surface book's own computer and my CCTV PC. I'd expect a lot more, which do show up on every single other machine without issue.

Pointers appreciated.

  • Try mapping the network drive (you might get different error message). Win10 tends to disable SMB1 protocol by default (supports for SMB2 or higher only), and if your server only support SMB1 only (and nothing higher) - this tends to happen. You can enable SMB1 on Win10, or if you have power on the server - update the server to support SMB2 or higher. – Darius Jun 26 '18 at 22:53
  • Please edit your question to include the relevant information with regards to SMB required to answer your question – Ramhound Jun 26 '18 at 23:01
  • @Damo If all else fails, run a Wireshark (or equivalent) trace on the Win 10 client and then attempt the connection, wait for it to fail, stop the trace, and then dig into the packets for more clue. See secpol.msc comment here: community.netgear.com/t5/Using-your-ReadyNAS/… and the other comments too for that matter as well as geekzone.co.nz/forums.asp?forumid=45&topicid=185246 .... Good luck getting this resolved but the SMB ideas as mentioned are worth a shot too. – Pimp Juice IT Jun 27 '18 at 2:17
1

I'm not entirely sure what the issue was or the resolution. Steps I took:

  • Updated Rackstation to latest image
  • Changed the supported SMB version on the RS several times
  • Ensured that SMB 1 / 2 / 3 were enabled in Win 10 via PS

when I try and use UNC alone, Win 10 doesn't want to pass over my custom credentials but if I map the drive in CMD I can enter them. This is the first windows 10 I've used with a Microsoft login rather than a local user, it will be the last.

  • Do you mean that it works with a local user, but not with a Microsoft account user? And if so, do you suspect any difference between a MSA Microsoft account and an Azure AD backed Microsoft account - or will both not work? – Terje Sandstrøm Sep 10 '18 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.