1

I noticed that my audio output (anything from system sounds to music) is leaking into my microphone.

Stereo Mix is disabled and the audio is not loud enough to be recorded by the microphone externally, probably it's crosstalk from the wires but I tried with a brand new headset (by the way they're both with 3.5mm jacks) and the problem persists.

I also tried (with both headsets) to connect the microphone and the headphone to different sides (microphone front and headphone rear, and vice versa), but still it leaks audio into the microphone, sometimes even when the microphone is disabled hardware-wise (with the button).

I know that probably there's something wrong with the motherboard' sockets but i noticed that TeamSpeak3 is the only software i know of that isolates audio output and input when selecting the "Windows Audio Session" option, so maybe there's a solution with a software that enables WASAPI for any application.

I'm not trying to record audio, i mainly use my microphone for stream and VoIP (Discord really detect any sound from the output and redirects it into my microphone, i can't listen to something loud without letting the other users listen to the same thing and if i lower the sensitivity they cannot hear me).

enter image description here

  • It's not clear from your question - do you have any sound at all coming from any speakers, or is it all just through the headset? – Tetsujin Jun 27 '18 at 17:22
  • it's all through the headset, i don't have any speakers, I also disabled every audio source except for "Speakers" which is the main sound output source – Iztooi Jun 27 '18 at 18:28
  • 'speakers' ... shouldn't that be 'headset' ? I think we need pics of your sound manager setup. – Tetsujin Jun 27 '18 at 18:42
  • output input (it's in italian but it's translated with "Speakers" and "Microphone") – Iztooi Jun 27 '18 at 18:56
  • I've added it to your post - it would appear you have the headset in the wrong socket :/ – Tetsujin Jun 27 '18 at 18:58
1

Found a fix for this, right click on speakers on the bottom right Click on sounds Click on playback Right click on every single item displayed and disable it except for the one you are using. Do the same thing for the recording tab. Test.

0

I have a similar issue with my Turtle Beach Earforce X12 headset and after doing some research, I can say one thing.

It's probably your headset(s).

With that said, I encourage you to watch this brief gif: example gif, explained below

In it, I play some audio in the background through my aforementioned Turtle Beach headset. Note how the input sensitivity is up near the middle of the bar. Around halfway through, I unplug my headset's output (leaving the mic plugged in) and switch it for a different pair of headphones. Notice how Discord is no longer picking up erroneous input. I should note that the mic is muted on the headset through this entire video, so this output bleed has to be coming from inside the headset (or Discord, but I am not in a position to judge).

My suggestion, is to see if you can use a different pair of headphones for your audio output and either get a budget external microphone or use your existing headset as a microphone only. Doing the latter is easy if your headset has two 3.5mm jacks so you can plug in the microphone jack but not the listen/audio output jack.

If neither of those options are convenient you can try setting Discord's input sensitivity above the typical peak amount when you're listening to loud music in the background, so at least it won't trigger automatically on your music alone. You may also consider push-to-talk. Lastly, you could also turn down the background audio when chatting on Discord anyway, but I realize that isn't a solution.

Also, as some of the comments have pointed out, it's worth checking if you have everything in the correct jack and that everything is setup properly software-wise, including in Windows and for your audio driver.

If you need any clarification, let me know, but I hope this helps.

  • I thought about using an headset as microphone only but it would be messy. I wonder how Teamspeak can isolate the two audio sources even if there's a faulty headset – Iztooi Jun 27 '18 at 19:13
  • I don't think that would be practical. If the headset is letting the output bleed into the output, I wouldn't expect any software to be able to do much to remedy that. – ChanceH Jun 27 '18 at 19:18
  • As far as i could understand the "Windows Audio Session" option is doing that. On Teamspeak, with the second headset when any sound is played there is no microphone output, unless I talk, but nothing is leaking through. – Iztooi Jun 27 '18 at 19:25
  • Is that not what you want? No microphone output when you play sounds (except for your voice, of course)? I'm also not aware of a "Windows Audio Session" option, you would have to enlighten me. – ChanceH Jun 27 '18 at 19:46
  • Yes that's what i want on TeamSpeak (and that works fine for that), but unfortunately that's not enabled on Discord or OBS option – Iztooi Jun 27 '18 at 22:11
0

The crosstalk problem appears to be an electrical design issue of the "common audio ground" of the mic and speaker jacks. Connecting an amplifier speaker to the headphone jack seem to not cause the crosstalk, its only headphones. The solution is to separate the grounds for the two connectors. I resolved it by running a separate ground wire from the rear pc stereo output jack's sleeve, by looping it around the speaker jack end, to the headphone jack's ground; as suggested in this question: electronics.stackexchange.com/questions/373716/pc-headset-crosstalk

-3

enter image description here

just change from 16 to 24 48000hz.. this worked for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.