12

VPN is blocking my attempt to allows Docker for Windows to share C: on windows 10 machine.

Works fine when im out off VPN. When its on I get

A firewall is blocking file Sharing between Windows and the containers. See documentation for more info.

The documentation says

You do not need to open port 445 on any other network. By default, allow connections to 10.0.75.1 port 445 (the Windows host) from 10.0.75.2 (the virtual machine).

I am "googled out" on trying to find how to do that - can someone advise?

I am usign docker 18.03.1-ce-win65 (17513), Cisco AnyConnect Secure Mobility Client 3.1.12020 and Symatec Endpoint 14.

When im on office and use cable everything works, but on home when I connect VPN I can't share drive with docker. Due to company policies, I am required to use this VPN client.

2
  • Did you ever find a solution for this problem?
    – Yoshiya
    Aug 22, 2018 at 20:01
  • Unfortunately not yet Aug 22, 2018 at 20:32

1 Answer 1

6

I haven't spent enough time to get this working on my specific environment, but this looks promising: https://github.com/docker/for-win/issues/360

They suggest changing the subnet address in Docker to something the VPN doesn't use.

Edit: If that doesn't work and your employer allows you to use another VPN client, I've had success using OpenConnect in place of Cisco AnyConnect.

5
  • Thanks for the suggestion, I tried this but I did not succeed. If you have another tip I thank you. Aug 31, 2018 at 17:53
  • I'll keep looking. I'm in a similar boat. I'm not sure if my company has a policy against using OpenConnect, so I'm doing that for now, but I'd like to get Docker and AnyConnect to play nicely. Aug 31, 2018 at 22:00
  • Were you able to configure OpenConnect to work on the VPN? Sep 3, 2018 at 15:12
  • I didn't have to do any configuration. I just used OpenConnect to sign in to my company's VPN and everything worked fine. Sep 11, 2018 at 15:01
  • 3
    This answer is correct, but to make it clearer what the fix is I created a blog post with pictures: lukerogers.com/2018/09/22/docker-file-sharing-w-cisco-vpn The key is finding a non-secured route and using that range for Docker.
    – Luke
    Sep 22, 2018 at 15:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .