2

I've recently installed Oracle VM VirtualBox on my Windows 10 computer, and I'm trying to make an Android Virtual Machine. The problem is that when I go to start the VM, it displays the following error:

VT-x is not available (VERR_VMX_NO_VMX).

Result Code:   
E_FAIL (0x80004005)  
Component: 
ConsoleWrap  
Interface: 
IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

I've already checked that my CPU is compatible with VT-x, and it's activated in the BIOS (In my case, I activated VT-d because there isn't an option for VT-x, but I've read that they're the same thing. If I'm wrong please correct me). I also have disabled Hiper-V, but it didnt' work.

Do you have any ideas on what's the cause of this problem?

Edit:

I have a Gigabyte GA-H270M-DS3H motherboard with the F7 BIOS Version. I have an Intel I7 7700 (not K) CPU

Regarding this post, I've tried everything there, except for turning on VT-x on the BIOS, because I don't have the option, and because I thought that VT-d was the same thing. If not, how do I turn on VT-x?

12
  • 1
    What CPU do you have? You say it's activated in the BIOS, but you activated Vt-d and not Vt-x because it isn't available. Vt-d is not the same as Vt-x. – DrZoo Jun 27 '18 at 18:05
  • Please list: CPU type and what happens if you try to install any standard OS (Windows, Linux) – AndrewQ Jun 27 '18 at 18:13
  • @DrZoo: I have a I7 7700 (Not K) CPU. The datasheet from Intel says that it has VT-x technology. By the way: My motherboard is a Gigabyte GA-H270M-DS3H. – ComputerUser121212 Jun 27 '18 at 19:45
  • 1
    Make sure you have Core Isolation, specifically Memory integrity, turned off since you are running Windows 10 Version 1803. If you cannot enable VT-x due to the firmware your motherboard has, then you will have to replace your motherboard, in order to enable. The error log, clearly indicates VT-x is not enabled, until you enable VT-x you won't be able to run the VM on the machine in question. – Ramhound Jun 27 '18 at 20:09
  • 1
    Windows Defender Security Center – Ramhound Jun 27 '18 at 21:00
1

What I did was turning off Core Isolation, specifically Memory integrity.

At first, I couldn't access this configuration, but, by changing the following registry key to 0, I could: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceGuard\Scenarios\HypervisorEnforcedCodeIntegrity\Enabled.

2

Not the answer you're looking for? Browse other questions tagged or ask your own question.