0

Windows 10 x64, Windows Update enabled, everything normal.

For some days, Windows Explorer has been slow for literally everything. Any action, whether it's a left or right click or anything (item, button, scroll bar button), or a "click in empty" to deselect an item, or a mouse wheel scroll, or anything, is always followed by the mouse pointer switching to the circular "loading" cursor for approximately 1.5sec and then back to the arrow and the action proceeds normally. (I can provide a video if needed) Obviously, using the explorer when everything has an 1.5sec delay is quite impossible.

As some posts here suggested it, I tried using Process Monitor to see what explorer.exe was up to, and ShellExView to disable all installed shell extensions, but it didn't change anything to the delay problem.

I have also tried disabling completely the Windows Search service, no effect.

I have done the standard memtest-chkdsk-sfc trifecta that the Microsoft support suggests every time you ask something on their forums.

Some people have suggested that this may be related to an HDD problem, but the problem only occurs specifically in Windows Explorer (listing files and working from cmd.exe is fast as usual) and it occurs no matter whether I am on an HDD, an SSD or even a RAM-disk.

Weirdly enough, the problem doesn't occur in other places where the Explorer "component" is used, like common file dialogs. There, browsing is blazing fast and I can double-click on a folder and it opens instantaneously.

I've been using XYplorer for a few days now and it works perfectly, although I highly prefer Windows Explorer, but it's become unuseable to the point that I don't really have other options.

I'm starting to run out of ideas, because I've tried almost everything that – I think – could be the source of this problem.

7
1

By analyzing the CPU usage of the trace with Windows Performance Analyzer, I see that every registry access involves MbamChameleon.sys calls.

enter image description here

This driver belongs to Malwarebytes Anti-Malware. So uninstall the tool because you run the Insider Preview 17692.1000.amd64fre.rs_prerelease.180609-1317 and 3rd party tool may not be ready for this RS5 preview version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.