3

I re-installed Windows 10 using a different disk. The permissions on my “My Documents” directory (D:\Users\Shimmy\Documents) look like:

enter image description here

Notably it is owned by “S-1-5-21-4050467196-1737195207-1040009286-1002”; i.e., a GUID that doesn't map to a name (probably a residual of the previous installation).  When I try to change the owner to the current user or 'everyone', I get the following error message:

enter image description here

The message says:

An error occurred while applying security information to:
<file name>
Failed to enumerate objects in the container. Access is denied.

How can I reclaim ownership on the disk/folder/file?

  • What happens if you try to change the ownership of the parent folder ("Shimmy") and ensure that the ownership is replaced recursively? – Kinnectus Jun 29 '18 at 11:57
  • If you don't mind me asking, what is your ultimate goal while you try to do this? When you first navigate to D:\Users\Shimmy within File Explorer you received a UAC prompt, correct? Once you acknowledged that using an account with admin privileges, you should be able to access everything that you need. Simply copy the contents of your pertinent folders (Desktop, Documents, Downloads, Favorites, Music, Pictures, and Videos) from your old profile to the new one. – Run5k Jun 29 '18 at 12:25
  • 1
    @Kinnectus your comment solved the issue. Please post as answer, thank you! – Shimmy Jun 29 '18 at 15:21
3

If you change the permissions of the parent folder - and ensure to select to replace ownership on all child items - then this should resolve the issue.

-1

The error generated for me was similar, giving me the following alerts:

"Could not create temporary file for 'C:\Users\Me\AppData\Roaming\ProgramX\ProgramXversion\ProgramX.tmp': Error opening file “C:\Users\Me\AppData\Roaming\ProgramX\ProgramXversion\ProgramX.tmp”: Permission denied"

After consulting this page and opening the Properties window for “C:\Users\Me\" (right click to open Properties),

I noticed that under Attributes, I had checked

"∎ Read Only (Only Applies to files in folder)".

This would certainly prevent any changes from being made to the folder and sub-folders in question.

Ensure that this, and the Hidden attribute (folder and subfolder visibility), is UnChecked, displaying the null box, before attempting further changes to the Permissions Properties, or else the changes won't take.

Make sure your Attribute settings display as unchecked

" □ Read Only (Only Applies to files in folder)" [and]

" □ Hidden"

Now you can proceed, and execute the requested permission changes to this folder and subfolders.

In event it asks for additional further confirmation for changes to some of the subfolders as it works through the queue, click on yes to proceed to finish.

I know this is the equivalent to the "Is it plugged in?" solution, but sometimes these small, overlooked details can be source of many problems, and are a simple fix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.