0

Installing Devuan Linux (Debian derivative), I get this error message:

The attempt to mount a file system with type vfat in /dev/nvme0n1p1 at /boot/efi failed.

During the installation, I did not specify to create a vfat file system (the SSD was empty), and I did not specify to create the EFI partition under boot/.

This is the SSD required partitioning structure:

/dev/nvme0n1p1 - 1.0 TB Unknown

  1 MB  FREE SPACE
 98 MB  ESP    EFI
 50 GB  ext4   /      /
 10 GB  ext4   var    /var
 68 GB  swap   swap   swap
  4 GB  ext4   tmp    /tmp
 50 GB  ext4   opt    /opt
500 GB  btrfs  home   /home
342 GB  FREE SPACE

I have not been able to get rid of the first 1 MB block of free space, but that should not be the problem.

The system is configured to use UEFI.

  • Do I need to add a /boot partition?
  • Do I need to add an ESP partition?
  • Is a 98 MB size EFI partition enough?
    • Does its size depend on the number of operating systems installed?

How can I fix my system?

1

Assuming UEFI/GPT in the answers below.

1 MiB Free Space

There are both fail safes and alignment reasons for that 1 MiB (also at the end of disks), so it should not be a problem.

/boot

You probably do not need a /boot partition. There are some specific cases.

ESP

Under the assumption above, you do need an ESP, and you do have one. ESP stands for EFI System Partition and UEFI (the U is dropped in some cases) stands for Unified Extensible Firmware Interface.

ESP Size

98 MB is most likely too small (uncertain if this is causing the error message though). Microsoft says 100 MiB is the minimum, though a good recommendation is 550 MiB.

Other Considerations

I have never installed Devuan and can therefore not answer about that specific error message. It could be a bug in the installer software. I have come across bugs that I suspect was related to it being a NVMe disk.

I do recommend increasing the size as described above. In addition, you only need ESP (/boot/efi) (possibly /boot instead) and root (/) partitions, but the others are fine. Also make sure that ESP has vfat (preferably FAT32) filesystem and the esp (or boot, esp) flag (sometimes referred to as EFI System or EF00). You can keep the other partitions as long as you do not try to have several ESP. Also the 68 GB swap seems excessive.

UEFI/MBR

My initial assumption might have been incorrect. If you use MBR ("dos") partition layout, then there is in some tools (e.g., fdisk) a bootable flag that has to be set, in fdisk it is shown as an asterix * in the Boot column when printing the table on screen. See this related Stack Exchange: Unix & Linux question.

However, it is usually recommended to use GPT layout with UEFI, please see the Gentoo Handbook and Arch Wiki.

  • I defined a /boot/efi partition as the first one, 600MB, FAT32. I cannot set the bootable flag to on. Is it fine? – Pietro Jul 3 '18 at 16:04
  • Confirming to write the changes to disk, I get: "No EFI partition was found". I will follow your suggestion, and restart from the automatic partitioning. – Pietro Jul 3 '18 at 16:26
  • I selected automatic partitioning, the EFI partition was set as bootable, I deleted the ext4 /home partition, I added a new ext4 /opt and a btrfs /home partition. Everything seems to be going on well now... – Pietro Jul 3 '18 at 16:41
  • I had the EFI partition with a 'b', which I guess should mean "bootable". – Pietro Jul 3 '18 at 17:03

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.