2

I use QtCreator 4.6.2, which apparently requires Python-enabled GDB if I want to use it as a debugger.

I tried to install mingw32-gdb-python version 7.5-1 with MinGW installer (graphical interface), and I got gdb-python27.exe file in my bin. But this file can't be opened. I'm getting error saying I'm missing python27.dll. I have Python 2.7 installed, and said DLL is located in C:\WINDOWS\System32. Obviously, System32 is in PATH, so it seems to me that it should be linked on demand.

Simply copying python27.dll to bin directory of MinGW throws an error "Application was not started correctly (0xc000007b)."

Running regular gdb (version 7.6.1-1) still does not allow python command (checked that in case gdb-python27 was only extension to normal gdb).

Did I miss some step here? Shouldn't MinGW provide me with python27.dll (it is a part of few other applications, like OpenOffice)? How can I make it work?

1

I was having the same issue. I found that it was due to using Python 2.7 64 bit, when gdb assumes a 32 bit python installation. Switching to Python 32 bit solved the issue. And you shouldn't have to move python27.dll anywhere if you use the 32bit version.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.