1

So I open visual studio installer, click modify on "Visual Studio Professional 2017 ver 15.7.3" and then receive the issue "The dependent package of 'Microsoft.Net.PackageGroup.4.6.Redist, version=15.0.27005.2' cannot be found: Microsoft.Net.4.6.FullRedist.NonThreshold,version=4.6.0.0."

https://i.imgur.com/u3EBkwz.png

Same error occurs if I try to uninstall VS 2017.

My initial thought was to simply reinstall .Net 4.6, but I have yet to be able to find any way to do so.

I have tried restarting, uninstalling the installer and reinstalling it. Restarting again, at this point I am at a loss of what more to try.

Edit:

When trying to perform install of .NET Framework 4.6 I get ".NET Framework 4.6 or later update is already installed on this computer" (Same thing occurs no matter which version I try to install) - https://i.imgur.com/UfEtDbR.png https://i.imgur.com/5pPvEk3.png

Os ver: Win 10 build 17134

  • Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. – Ramhound Jun 30 '18 at 19:56
  • In order to answer this question I need to know what version of Windows you are using. If it’s Windows 10 include the build number. – Ramhound Jun 30 '18 at 23:42
  • Win 10 build 17134 – Sora Jul 1 '18 at 3:29
  • If you have 1803 then your machine has 4.7.2, which means, you can’t install 4.6. As for the error I would attempt to download the VS2017 installer again. – Ramhound Jul 1 '18 at 12:59
  • I have already downloaded and tried to reinstall the installer, no change – Sora Jul 2 '18 at 9:00
2

Got a response from the MS support team, the issue was due to a file managing the installations got corrupt.

The solution to this was:

Please follow the cleanup steps and retry your VS install

  • See if you have this file on your machine: "%programfiles(x86)%\Microsoft Visual Studio\Installer\resources\app\layout\InstallCleanup.exe"
  • If so, please launch it from an admin command prompt with a -full param:

InstallCleanup.exe -full

  • If not, please manually delete the "%programfiles(x86)%\Microsoft Visual Studio\Installer” folder
  • Relaunch the newly downloaded vs_enterprise.exe (or vs_professional.exe or vs_community.exe…)
  • Allow the first step to install the installer
  • Once the installer comes up and you can see workload choices (.net desktop and the like), close it
  • Go launch the same InstallCleanup.exe to clean up old build of VS
  • Then relaunch vs_enterprise.exe and install VS
  • -1. Lost the programme after using the installCleaup.exe -full. And launching the installer doesn't work anymore. The programme is still listed under softwares, cannot remove it. – SamChen Dec 18 '18 at 6:36
0

Go to this page: Microsoft .NET downloads

You should be able to download the proper version of .NET there.

  • I have added an edit in the first post, when I try to do an install I get an error due to "4.6 or a later update already installed" – Sora Jun 30 '18 at 17:53
  • do you have the correct developer pack installed? Go to this page: Developer Packs – HippyDippy Jun 30 '18 at 18:05
  • I do yes, i.imgur.com/5pPvEk3.png (removed previous comment as I couldnt edit it) – Sora Jun 30 '18 at 18:22

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.