0

OS: Windows 10 Pro (Build 17134.137)

Touchpad driver: Synaptics Pointing Device from Lenovo (version 19.0.17.115, September 19, 2016)

PC: Thinkpad W520

Steps to reproduce:

  1. Navigate to additional mouse options.

UltraNav settings screenshot

  1. Navigate to TouchPad Properties.

TouchPad Properties screenshot

  1. Ensure that two finger scrolling is disabled.

Two finger scrolling setting screenshot

As you can see from the last screenshot, two finger scrolling is disabled on my system, yet the touch-pad still begins to scroll when I have two fingers placed on it. It's jarring and irritating and I'm not used to it at all.

Strangely enough, the setting seems to stick when I open UltraNav settings and close it. But two finger scrolling returns after a restart. I don't know if this is an issue with a driver or my configuration of Windows 10...

I've tried the following:

  1. Rolling back the driver, which didn't resolve the issue.
  2. Deleting the driver and re-installing it via Windows update and from Lenovo's website. Also didn't resolve the issue.

Does anyone have a permanent fix, like maybe a registry edit that completely disables all additional touch-pad gestures like this one?

1

Though I cannot provide a definitive answer, you should find the settings for the touchpad in two Registry keys:

HKEY_CURRENT_USER\Software\Synaptics

  1. HKEY_CURRENT_USER\Software\Synaptics (There may be more than one set of keys.)

HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTP\Defaults\2FingerGestures

  1. HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTP\Defaults\2FingerGestures

The first contains user settings and the second defaults, to which the device might be reverting after reboot.

Though I don't condone poking around randomly in the Registry, you might try the following procedure to find locations being changed, using a third-party tool, such as Nirsoft's Registry Changes View.

  • First, back up the Registry before making any changes.
  • Open the Registry comparison tool.
  • Make a snapshot of the Registry saved to a convenient folder.
  • Change the Synaptics Touchpad two-finger scrolling setting and apply it.
  • Make a second Registry snapshot.
  • Compare it with the previous one.

Registry Changes View

On my laptop, the value DisableGestures changed from 56 to 60, so it appears that the two-finger-scroll setting is stored as the bit in the fours place.

Once you discover this for your laptop, you can then change ownership of the key to TrustedInstaller to prevent it being changed back by the system. You can also change the defaults in HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTP\Defaults\2FingerGestures to suit your preferences.

You might also make a .REG export of the key with your preferred settings, to revert after a driver or Windows update changes settings for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.