1

My mouse wheel has started doing that thing where it scrolls up a few times if I'm scrolling down.

Here's my mouse settings (Windows 10 Settings window AND Control Panel mouse properties).

enter image description here

Its a Redragon Centrophorus so I don't really expect miracles but I took it in to the shop I where I bought it, they plugged it into a pc and the scroll wheel scrolls perfectly fine there.

I've tried a different USB port on my pc but the problem persists. I'm not sure what to try.

  • it's definitely not related to the settings but some physical hardware problem. That's why it doesn't depend on which USB port you've plugged in. Try cleaning the mouse or buy a new mouse – phuclv Jan 6 at 8:37
0

The mouse wheel has a series of small slats or spokes that are read optically as it turns.

I guarantee you have a little ball of hair and lint blocking the light.

Careful disassembly and something like a toothpick to clean the optical path will fix it.

  • This worked for me, just removed the dust inside. – Anna Ira Hurnaus May 8 at 19:32
0

Possible solution is : turning off the option "Allow themes to change mouse pointers". You can do this by going to : Control panel>Hardware and sound>mouse Then select the tab "Pointers" and uncheck the box that says "Allow themes to change mouse pointers". [windows 7 tested]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.