I have 4 TB Western Digital my-passport drive. When I copy a folder with large number of files, the copy (or move files) dialog just sits there forever without returning but no further copying takes place. It usually does copy some files but it gets stuck at some point.

I don't have any particular files that are over 4 GB and file system on drive is also NTFS so it's not an issue of one large file. But what I am copying is a big folder over 15 GB.

When I run "Western Digital Data Lifeguard Diagnostics" tool on the drive, it does detect too many bad sectors. However, I ran windows scan disk with option to repair errors and it doesn't find any errors.

I also went into Device Manager >> "Disk Drives" >> "My Passport" and turned off "Quick Removal" under "policies" tab and changed to "Better Performance" which was supposed to help but it didn't.

So I am confused, are there really bad sectors on the disk that WD tool tells me or the problem is something else and in that case why I can't copy a large folder?

  • if you want to have chkdsk check for bad sectors you must use \R (the capitalization is important). I'd try to check the SMART stats instead though. you don't have to wait forever to see if there are in fact reallocated sectors. if you do have more than a handful of bad blocks, its time to get a new disk. – Frank Thomas Jul 2 '18 at 18:30
  • @FrankThomas Well to be precise, I run chkdsk through UI in windows file explorer because I think that's what it uses? What I did was right click on drive >> Properties >> Tools tab>> "Check now" in error checking group and "Scan for and attempt recovery of bad sectors". Should I run it through command line? – zar Jul 2 '18 at 18:48
  • did it take 8-12 hours? if it didn't, it didn't check the whole. if your disk supports SMART, it really is the best bet to check it. I use Speedfan in windows to check SMART stats. Look at Current Pending Sector count, and Reallocated Sector count. – Frank Thomas Jul 2 '18 at 18:50
  • @FrankThomas Yes it took like that. I don't know about SMART but it should support it because its a brand new disk. Let me look into that. – zar Jul 2 '18 at 18:55
  • @zar, have you run CHKDSK /F /R against the source? And whenever I need to run CHKDSK, I do so from an elevated command prompt. – BillDOe Jul 2 '18 at 18:56

I am posting my findings as the answer.

It seems the problem was the folder itself. I noticed I could actually copy it to the external drive but it was the "move" which was getting stuck. It's still unexplainable why though.

If I redo the move/delete and repeat the move, I noticed it gets stuck exactly at the same point again (same bytes copied).

I tried a new hard drive and the move still getting stuck at the same point so there is some permission issue or something else.

Anyways the copy does work and my main worry was if there were bad sectors on this new disk but it seems like the disk is fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.