7

My audio stopped working this morning out of the blue. I had recently updated Windows 10 to version 1803 and have read a couple of articles that say it's somehow related to it. But it was working yesterday and I did the update a week ago without having any problems whatsoever.

I know that it's complaining about the services, and my best bet is to look at the windows services.msc, so I found out that Windows Audio was set to automatic but did not start. And whenever I try to start it, I get a 0x8007005: Access denied error.

Which then led me to another article and told me to go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wcncsvc and change the permission to full grant. But I still am getting the access denied error anyways.

Is there a fix or am I forced to either downgrade, do a system restore, etc..?

4
  • Scan your system for an infection, something changed the windows audio permissions a week after the update.
    – Moab
    Jul 2 '18 at 22:45
  • @Moab I did this morning and didn't find any.
    – Ray
    Jul 2 '18 at 22:47
  • re check that registry permission to be sure the changes stuck. Also was it a full system scan or quick scan?
    – Moab
    Jul 2 '18 at 22:49
  • It did. I have CREATOR OWNER, SYSTEM, Adminstrators, and Users set to full control. Only ones that are not are ALL APPLICATION PACKAGES and Account Unknown.
    – Ray
    Jul 2 '18 at 22:52
10

had the same problem, the normal recommendation for restarting "windows audio" via services.msc didnt work for me. finally figured it out.

open services.msc find "Windows audio" right-click on it, properties->log on tab-> select "log on as local system account"

1
  • 7
    This got the red X to disappear from the tray, but I'm still getting no sound.
    – LCialdella
    Sep 18 '18 at 14:31
4

I tried:

  • Starting the service
  • Changing the audiosrv user
  • Giving access permission to the service and various parts of the registry
  • removing and re-installing the audio drivers
  • removing hidden items in the device manager
  • importing registry sections from other computers with working audio

Nothing helped (0x8007005: Access denied, later "Audio services not responding") Finally I found these:

net localgroup Administrators /add networkservice

and

net localgroup Administrators /add localservice

Enter them in elevated command prompt (run as Administrator) then reboot. Voi'la!

Found it here: Fix: Audio Services Not Responding Windows 10.

1
  • I know this is an old post, but for anyone having this issue, this should be the first thing you try. Nothing else seems to have worked, at least in my case.
    – Dominik H
    Apr 16 '20 at 15:42
1

This is more of a work around than a fix but it works for me:

  1. Log in as a user with admin privileges
  2. Open notepad and type NET START audiosrv
  3. Save file in C:\ or somewhere you can find it easily, also make sure its saved as a batch file (enter .bat at the end of the name)
  4. Open Task Scheduler
  5. Create Basic Task
  6. Type a name (e.g Audio Recovery) then Next
  7. Choose the option “when I log on” then Next
  8. Choose Start a program then Next
  9. Browse and select the batch file from earlier and Next
  10. Check the box and click Finish
  11. In the General tab, choose Run whether user is logged in or not
  12. In Triggers tab click Edit
  13. Change specific user to the affected user’s profile
  14. Choose to Delay task for 30 seconds and click OK
  15. Click OK again then log out and in and it should work
1

I had a similar problem. My Audio services was running, but I got a red cross over the volume control icon and I had no sound.

Windows troubleshooter for audio complained that the audio services was not responding, but offered no action to remedy the situation. And they were definitely running.

At first I thought it was the drivers so I re-installed all of them, but could not get any sound from any of the audio devices (built-in, PCIe card or Bluetooth headset).

I tried all the "restart Audio services" tricks I could find, but to no avail.

Another tip was to ensure that the services was running as the local system account (Services->Windows Audio Service->Properties then the "Login" tab). This did not work either.

But looking at another Windows 10 computer (with working sound) I discovered that the service was running as "Local service" (I think that is the term, my computers are in Swedish ;-), NOT as the local system account.

Login tab of service properties

Changing to these settings restored all my sound!

Translations:

"Inloggning" = Login
"Lokal tjänst" = Local service
"Lokalt systemkonto" = Local system account
1

This is an old question, but i will leave the solution here for reference.

I've had the same problem for a while but was able to fix it. • First I downloaded procmon.exe from http://live.sysinternals.com/procmon.exe • I ran procmon.exe and added a filter looking for "Result is ACCESS DENIED" • I then attempted to start the Windows Audio service and found it was complaining about not having access to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices • I browsed to that key in Regedit and added Everyone Full Control • Attempted to restart the service and voila, started and Audio was working. Might be the same key in your situation, or it might be another key. At least with Procmon you can find out what it's complaining about.

Source: https://answers.microsoft.com/en-us/windows/forum/all/windows-audio-service-doesnt-started-with-error/a6d1f572-4b32-4977-8b72-15d4e2042bf7

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.