3

I have an Excel spreadsheet located in a folder on a network drive. I want to include hyperlinks to images. These are in a sub-folder. If I insert the hyperlinks in the spreadsheet cell, these are added with relative path. Because of this if I email the sheet the hyperlinks are broken for the reader.

On the other hand if I copy the file somewhere else and insert hyperlinks as they were before in that original sub-folder, these hyperlinks are added with absolute path. They work in the email.

How can I tell Excel to always put the absolute path for hyperlinks?

Here is an image of what the Insert Hyperlink dialog looks like when the link works in email. Note how Excel puts the full path.

enter image description here

Here is an image of the dialog when the hyperlink is broken when accessed in an email message.

enter image description here

The file is the same but in the first image I copied the file to a folder on the computer before inserting the link. In the first image the file is on the same network drive as the file that I link to.

It looks like Excel only puts the full path if the inserted link is on another drive or directory structure.

I haven't tried the Hyperlink function. But since someone will be using the sheet, I want to stick to the Insert Hyperlink feature if possible.

1
  • Try to File- Options- Advanced- uncheck the option "Save external link values."
    – Lee
    Commented Jul 5, 2018 at 8:31

3 Answers 3

1

Rather than insert a hyperlink using that method,

You can use the formula =HYPERLINK

This will keep in place the absolute file path for you.

Find the file location through browser and copy it.

enter image description here

Then use it within the formula:

=HYPERLINK("\\uk.finning.com\data\Group\Heavy Construction\New Sales\ORDER FULFILMENT TEAM\Deal Sheet\filename.xls")

Don't forget to add the document name and file extension also.

0

Well you could argue that Excel was actually more wrong in the firs case since it added mapped drive name instead of the full net path (which will make it totally undiscoverable from another box unless it has the exact same mapping), while the relative path will be discoverable if both files are copied.

You could go and read up this: https://support.microsoft.com/en-us/help/328440/description-of-link-management-and-storage-in-excel

but in general, if you want full control, you'll have to paste full UNC paths manually and make sure that document is read-only if Excel tries to get "too smart".

0

enter image description here

Try, and this is the technical term, try dicking around with this setting. Should make all paths you put in NOT be automagically "fixed" by Msft. YMMV.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .