0

I'm trying to install ZABBIX monitoring software with yum on a server. When I attempt to install the package, yum prompts me to update php to 7.30.0.

Installing:
 OpenIPMI-libs                        x86_64                  2.0.23-2.el7                    base                      521 k
 OpenIPMI-modalias                    x86_64                  2.0.23-2.el7                    base                       16 k
 dejavu-fonts-common                  noarch                  2.33-6.el7                      base                       64 k
 dejavu-sans-fonts                    noarch                  2.33-6.el7                      base                      1.4 M
 iksemel                              x86_64                  1.4-6.el7                       epel                       50 k
 zabbix-agent                         x86_64                  3.4.11-1.el7                    zabbix                    365 k
 zabbix-server-mysql                  x86_64                  3.4.11-1.el7                    zabbix                    2.0 M
 zabbix-web                           noarch                  3.4.11-1.el7                    zabbix                    2.7 M
 zabbix-web-mysql                     noarch                  3.4.11-1.el7                    zabbix                    6.9 k
Installing for dependencies:
 php70w-ldap                          x86_64                  7.0.30-1.w7                     webtatic                   35 k
Updating for dependencies:
 php70w                               x86_64                  7.0.30-1.w7                     webtatic                  2.8 M
 php70w-bcmath                        x86_64                  7.0.30-1.w7                     webtatic                   38 k
 php70w-cli                           x86_64                  7.0.30-1.w7                     webtatic                  2.9 M
 php70w-common                        x86_64                  7.0.30-1.w7                     webtatic                  1.2 M
 php70w-devel                         x86_64                  7.0.30-1.w7                     webtatic                  2.5 M
 php70w-fpm                           x86_64                  7.0.30-1.w7                     webtatic                  1.5 M
 php70w-gd                            x86_64                  7.0.30-1.w7                     webtatic                  136 k
 php70w-intl                          x86_64                  7.0.30-1.w7                     webtatic                  181 k
 php70w-mbstring                      x86_64                  7.0.30-1.w7                     webtatic                  543 k
 php70w-mcrypt                        x86_64                  7.0.30-1.w7                     webtatic                   28 k
 php70w-odbc                          x86_64                  7.0.30-1.w7                     webtatic                   52 k
 php70w-opcache                       x86_64                  7.0.30-1.w7                     webtatic                  131 k
 php70w-pdo                           x86_64                  7.0.30-1.w7                     webtatic                   93 k
 php70w-process                       x86_64                  7.0.30-1.w7                     webtatic                   43 k
 php70w-soap                          x86_64                  7.0.30-1.w7                     webtatic                  174 k
 php70w-xml                           x86_64                  7.0.30-1.w7                     webtatic    

          130 k

The thing is, I know for a fact that updating php to this version makes it so that it doesn't work correctly with the old version of zend I'm running. Additionally, the zabbix documentation states that php version 5.4.0 or later should be compaptible with the version I'm running, which is 7.0.27.

My question is, shouldn't Zabbix work correctly without updating php or am i missing something? If so, is there a way to work around this problem on Yum? Also, I should mention that ldap is not used for authentication so it shouldn't be required either.

Thanks!

0

Try with yum exclude option. -x, --exclude=package Exclude a specific package by name or glob from updates on all repositories. Configuration Option: exclude

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.