1

Whenever I download a file from a browser, or just save a document to the desktop, the icon always shows up on my secondary monitor. Not the primary. So I'm constantly having to minimize windows on my second monitor in order to click & drag the icon to the primary monitor.

In my Google searching of this problem, the only thing I was able to find on it was this one Microsoft Answers page. Anyone got any ideas?

EDIT: Here's 2 screenshots from my display settings. #1 is the primary. It's the one that has all my system tray icons & desktop shortcuts. However, saved files always show up on #2.

enter image description here    enter image description here

6
  • Please provide a screenshot of your display settings within the Settings UWP application. Be sure to provide a screenshot with each monitor selected. In the edit, you will provide be sure to mention which monitor the files are appearing on (it won't be obvious from the screenshot)
    – Ramhound
    Jul 5 '18 at 14:07
  • There's a difference between "pimary monitor" and "primary desktop" Make sure you've selected your desired primary desktop in your multiple monitor setup. You'll know which one is the primary desktop because it's the one that will have the system tray items shown in the taskbar - the others will not. Jul 5 '18 at 15:24
  • I assume you have hit Identify, and configured the configure, is what you expect it to be? I would suggest switching, the main monitor to display 2, then switching it back.
    – Ramhound
    Jul 5 '18 at 18:26
  • @Ramhound Yes, it is what i would expect it to be and I've already tried switching the main display to the other monitor, then back again. Jul 5 '18 at 20:37
  • 1
    @Ramhound Well, I seem to have figured out what was causing the problem. I'm using Stardock Fences (stardock.com/products/fences). After temporarily disabling that, saved docs go to the primary monitor. Guess I'll start bugging them about it. Jul 6 '18 at 0:02
1

I seem to have figured out what was causing the problem. I'm using Stardock Fences (stardock.com/products/fences). After temporarily disabling that, saved docs go to the primary monitor.

2
  • See Fences Settings > Layout & Snapping > Layout auto-adjustments - check the checkbox under that section to see if it resolves the issue.
    – JW0914
    Nov 27 '19 at 12:14
  • I cannot find this option in Stardock Fences version 3.0.9.11
    – Sibo Jiang
    Apr 6 '21 at 14:54
1

I found another possible cause. After right-clicking on desktop->"Display Settings", I scrolled down and noticed that "Multiple displays"->"Make this my main display" box was checked for the wrong monitor. Even though my desktop was shown on the correct display.

Selecting the correct monitor for "Make this my main display" corrected the issue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.