3

UPDATE: This issue has very suddenly disappeared.

Below are some details of when it disappeared, in case anyone knows of anything I don't that might have solved it and subsequently help others. Below that is the original post so people are able to see the whole issue. Though I am not having the problems anymore, this is as yet unsolved.

I have been using my workaround that I mention at the bottom since a few days after posting this, while trying to find a more long-term solution. I have also been monitoring task manager while I am doing things for a few minutes on most days, to see if the problem was still there (when I hit 80% GPU usage on the 1060, I know it's still broken as that would make the integrated GPU cry).

Recently got an external HDD, so I decided I would admit defeat, put all my stuff to keep onto that, and do a completely clean Windows install (the one that erases all files etc). Started that this morning and had everything on my external HDD ready by this afternoon, so I reenabled the Intel driver (as in, stopped using my workaround) just in case it being disabled during the install broke something.

As I was doing my last checks over all my work and stuff to ensure I hadn't missed anything, I noticed I was having no issues whatsoever - opened task manager and no matter how hard I try, dwm and csrss don't get higher than around 10% on the integrated GPU, and that's was when I was opening a new window and shaking it around.

I haven't installed, uninstalled, or deleted anything at all in over a week, and I haven't had an update to Windows since 12th July - right after the problem started happening. Relevant drivers are all the same versions that I force-installed 4 weeks ago to try fix the problem - no updates since then (can't comment on other drivers that seem to be unrelated as I didn't know their previous version numbers). Haven't found any more suggested solutions in over a week a week, so I hadn't been trying anything.

The only things that I can think that are possibly related are:

  1. I rendered another video using the same software (Resolve) that it (potentially) broke with, and I used the same project as before (I use it as a template), so maybe in rendering another video it overwrote a corrupt temp file or something? Not at all convinced though, because I did render a video immediately after I started noticing the problems last time, and I don't even know if the failed render last time had anything to do with it - that's just when I started noticing it.

  2. Without disabling the workaround, I disconnected my main second monitor last weekend and swapped over to a different one so a few of us could all watch TV on a large screen. At no point did I ever enable the Intel Graphics drivers, I just turned my laptop off, moved it and wired it up, and turned it on again (as one would if there was nothing wrong). Not sure whether this would have anything to do with it, but knowing Microsoft I wouldn't rule it out. Seems far fetched imo for this to be the fix but it's all I can come up with that's relevant.

If anyone does find a solution or knows something I don't about a recent Windows update, how Resolve works, or anything else that might explain its sudden appearance and disappearance, would be interesting and helpful to know.

-=-=-=-=-=-=-=-=-=-=-=-=- Original Post: -=-=-=-=-=-=-=-=-=-=-=-=-

I have a laptop running Windows 10 version 1803 - I updated to 1803 it just over a month ago. Laptop has a GTX 1060 and integrated Intel(R) HD Graphics 630.

Last week, I noticed a lot of lag doing not a lot. Mouse pointer was lagging, moving windows around was choppy, etc. Fired up task manager, and Client Server Runtime Process - csrss.exe - and Desktop Window Manager - dwm.exe - were together using around 80% of my integrated GPU. Not moving anything drops the usage down, but as soon as I move the mouse or drag any window, it shoots back up. The laptop runs at normal heat, it isn't overheating at all.

I first noticed it after I was rendering some videos and forgot to plug my laptop in - it ran out of charge and powered off and the render obviously failed. I tried altering power settings when I turned it back on, but they didn't change anything.

It's not that my hardware isn't capable - I've seen lots of suggestions saying "use a plain wallpaper and disable transparency effects". The hardware is more than capable but I tried it anyway just to make sure, and even with a plain background and all animations off, dwm.exe still used the same amount.

Went through the usual process of checking for updated drivers - according to Windows, both were up to date, but I downloaded and installed the latest from both Nvidia and Intel to make sure. The Intel driver is Intel(R) HD Graphics 630 version 24.20.100.6136. Checked for Windows updates, and there was an update to 1803 which I installed but it was nothing to do with the issue and didn't fix it.

Scanned for malware (I thought it could possibly be a poorly written miner or something that was using my integrated GPU rather than the way more powerful 1060) but neither Malwarebytes or Windows Defender found anything, I didn't install anything for days before I noticed it, and both dwm.exe and csrss.exe are still located in System 32.

Went into BIOS (Phoenix Version QP123), there was nothing relevant in there.

Have tried restoring old versions of Windows, but they all fail quite ambiguously, with useless messages like "Unable to restore previous version".

Others online have said that reinstalling Windows hasn't worked, which I find curious, but I haven't tried and of course it's a last resort.

I found an inconvenient workaround which is to disable the integrated driver and reboot, forcing my laptop to use the 1060 for everything. This means that it can handle dwm.exe and csrss.exe using so much GPU, but it doesn't actually fix the problem, and also seems to cause weird system instabilities (sometimes I get bluescreens, sometimes it crashes if I restart).

I ran the Windows Driver Verifier to try and rule out driver issues once and for all, but that got my laptop stuck in a bootloop. Interestingly, when I ran it in safe mode to fix the bootloop, the initial issue went away - it wasn't laggy at all (though I can't tell you the GPU usage because safe mode).

I caved and chatted to someone from Microsoft, they were pretty useless but said I should try an "in-place upgrade". Installed from their site, needless to say it had no effect.

Since then I've tried running a few other things - Win+r and msdt.exe /id PerformanceDiagnostic tells me the troubleshooter doesn't work on my version of Windows. Used msconfig to perform a clean startup and the issue still persisted.

Pretty lost as to where to go from here - I have found some similar issues, but they're all from pre-Windows 10 and give solutions that are no longer relevant.

  • Please edit your question to include the Intel HD Graphics 630 driver information – Ramhound Jul 6 '18 at 15:01
  • re: using 1060 "doesn't actually fix the problem". When you move the mouse or drag windows around, or even just drag a selection across the desktop, large areas of the screen are "invalidated" and redrawn (e.g. InvalidateRect() or WM_PAINT message). This is normal behavior. I have a 1050 and I can get the gpu usage up to about 16% by dragging a selection box on the desktop around rapidly without releasing the mouse button. I agree though that 60-80 sounds high. – Yorik Jul 6 '18 at 17:03
  • @Ramhound Have included the version in bold – Jack Jul 8 '18 at 16:29
  • @Yorik The 60-80 figure is for the integrated Intel card, however it's only recently become an issue. For around a year, they've never been so high - even 16% on a 1050 seems excessive, I am not sure why you get that. – Jack Jul 8 '18 at 16:31
  • 1
    @Kyralessa No progress at all. I'm still using my workaround with disabling the Intel, but it's still spiking the 1060 often. At some point this week I'm going to do a clean reinstall of Windows - will let you know if it fixes it. – Jack Jul 29 '18 at 19:06
0

I've recently taken notice of csrss.exe and dwm.exe using a small percentage of my GTX 1070 (only about 3% at this point). While this is hardly notable compared to everyone's issue here, it was curious enough to draw my attention. After skimming through Reddit and Microsoft threads, I ran across a few interesting troubleshooting possibilities.

  1. From Task Manager find dwm.exe, right click, go to details, right click again, check if priority is set to High. If so, reduce to Normal
  2. Access the NVIDIA Control Panel and change dwm.exe to use Integrated GPU, though dwm.exe may need to be added manually, and using integrated GPU may not be an option for all.
  3. Some Dell Support Reps seem to believe Kaspersky software and SmartByte Drivers/Services may be a contributing factor to this issue, to which they've advised to uninstall both, should you have them.
  4. Dell users have also reported some improvement by way of updating the BIOS and the Dell Delivery Application. Sources for these are as follows:

Dell Digital Delivery Application (http://www.dell.com/support/home/au/en/audhs1/drivers/driversdetails?driverId=YD63W) which was updated on 4th June 2018.

Dell XPS 15 9560 System BIOS (http://www.dell.com/support/home/au/en/audhs1/drivers/driversdetails?driverId=HJKH8) which was updated on the 26th April 2018

In an effort to determine a more definitive cause, I'm attempting to research the offending process's dump files and, via SysInternals, their thread and module behaviors as well. Just on the surface, I have seen several interactions with dll files from Kaspersky, as well as a component of Windows Framework... Microsoft.UI.Xaml.

I've been unable to pinpoint any specific cause or reason as of yet, but as widespread as this issue seems to be, I'm beginning to lean towards a software issue on Microsoft's part... communicating and/or interacting with particular hardware incorrectly or inefficiently.

[EDIT] Please note that this has/is affecting users with graphics cards that are not integrated OR manufactured by Intel. The symptoms appear to be the same, but the remedy to these issues may end up being totally different. To post an update to my problem in particular, dwm.exe seems to be using more than I originally mentioned. It is now increased to around 6% to 10%.

While I'm putting efforts into resolving my own issue, I can't help feeling doubtful that I'll succeed... on that note, I'll check back with the thread, here, and hope for progress of any kind. If any of the suggestions I posted above prove helpful to anyone, it may actually be helpful to post back with information about your system (hardware AND software).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.