Since today suddenly both my USB ubuntu installations (2 different USB sticks) try to boot and nothing loads but all I see is a message saying "Boot Error".

When I press space it continues booting from the main hard drive. I tried reinstalling ubuntu on the USB stick but same error.

This only happens on 1 computer and started happening today, before it worked just fine.

Any idea what's causing this ?

Regards, Xeross

Update: Look like it isn't PC specific, and both the USB sticks somehow got corrupted, any idea to why/how this could have happened ?

3 Answers 3


Turns out it really was corrupt, it also stopped working on the other computers.

For some reason it seems that USB installs of Ubuntu are really fragile and break easily for some odd reason. Is the MBR of a USB stick overly sensitive or something, makes me wonder. So people, back-ups!


If it boots in one computer and not in another, it may be your bios boot settings (I don't think it's a virus, but maybe you should check that).

I don't know, it could have some hardware failure, those memory sticks. It's rare that it happens in both at the same time, but it can happen. (if they suffered from same physical external aggression, no idea...)

Oh, you say it's not single pc specific. Well, I'd check if in the usb disk, if you can browse it from another computer, the config files surely of grub have been deleted or something. Also, maybe it got wrecked some how the MBR, the master boot record. It's strange that it happened in both. In Windows, it's common that viruses do infect and wreck the boot area, but...

Also, to deal with grub boot problems, you may wish to go to another computer, make a boot floppy disk, cd or usb with supergrub, it helps in fixing several boot problems, although I have not used it. When I lose boot, it happens rarely, I use whichever boot manager to recover it, and if Windows, even just a DOS command. Supergrub is here: http://forjamari.linex.org/projects/supergrub/. You can recover it in other ways, too. But this is probably easy. In case this is what happened.


I guess you should use universial usb-installer as recommended in the official site of ubuntu. and I came across this problem too. But I guess that's because some pc or server board recognised the usb as a usb hard disk!

  • Could you post a link to this "universal usb installer" ? Dec 28, 2011 at 18:14
  • universal-usb-installer Previously I use the highly recommanded netbootin but the usb-disk it create always encountered strange problems. By the way,not sure wether it is your case,you'd better format you usb as FAT32,not NTFS.(It's not explicitly stated that NTFS is not supported,but I found NTFS format did caused problems)
    – allan ruin
    Dec 30, 2011 at 5:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .