1

Error Dialog

This issue is specific to a single computer and a specific file, in a specific shared directory.

The file cannot be opened, in its current directory, by any user, from this one machine.

The file can be opened in its current directory, from any other machine by any user.

The file can be copied or moved to a sub-directory within the current directory and opened fine, from any machine/user (including this one).

The file can be copied to a local directory, on this machine, and opened fine.

All other databases and files in this directory open just fine, from this machine.

This file is the front end of a split database; all external connections from other databases, and the backend of this database, work without issue, from any machine/user. The backend opens fine too.

Copying, renaming, decompiling/recompiling and re-uploading; all have no effect. (Even uploading a re-compiled copy as Test.accdb to that directory didn't work.)

The problem machine is a recent clean install, of Windows 10 and Office 365 ProPlus, on a new Samsung EVO 860 SSD.

Coincidentally, an original version of this file, with an appended name, in that directory, created long before this issue, or Windows install occurred - no longer opens from this machine either. (When I make file changes, I edit a copy first, then rename both files accordingly, to facilitate a seamless transition and roll-back if necessary. All users use desktop shortcuts for file access.)

All backup copies saved in a sub-directory of this one, and remotely, all open fine (90 days worth), from their perspective directories.

The problem file is hosted on a local server, in a shared directory.

I can remote into the server from this machine and open the file just fine.

Several weeks went by after installing Office/Windows, before this issue developed, and it has not been intermittent; I have not been able to open this file, in that directory, from this machine, since the first error popped up.

I have removed/reinstalled Office twice.

The server and directory are not mapped; mapping them changed nothing.

The only references to this file in the registry are in MRU lists.

Using the command line, browsing to the directory, clicking a shortcut, running as administrator; all result in the same error above.

The only thing that has not been tried, is reinstalling/repairing Windows.

Update: 7/20/2018

Reset Windows 10, with "Do Not Keep Files" option; same errors.

Other databases, that I do not use regularly, are displaying similar behaviors.

Updated/Rolled back, to different versions of Office, that work on comparable machines/OS's; same errors.

This same PC is throwing Run-Time Error 2004's when printing to a specific printer from Access; even though all other printers local and network, have no issues, from this PC.

When printing from other programs to the printer with errors, the que displays "Printed" immediately, but nothing prints. No other machine has these issues, with files or this printer.

Update: 7/23/2018

We were able to replicate on another Windows 10 PC connected to the domain, while another Windows 10 PC on the same domain, with all of the same updates, doesn't exhibit any of these issues.

I put my old SSD back in today, and migrated Windows 7 over to the new drive, so I could that get back to work.

Side note: A couple of Bar Charts, that I created from this machine, in other database's reports, while it was a Windows 10 install; vanished from the their parent reports, when opened from this PC after migration, and consequently, were no longer present on those reports, when the databases were opened from other computers as well... no changes were made to the reports - the graphs were there yesterday, and gone today. Which makes me wonder about another issue, not listed above; while this PC was a Windows 10 install, no graphs would display in Print Preview, and subsequent print outs, of the parent reports, were sans graphs.

As we gradually replace our 7 machines with 10, these issues may return; but for now - I gave up.

  • Can you clarify "Copying, renaming, decompiling/recompiling and re-uploading; all have no effect. (Even uploading a re-compiled copy as Test.accdb to that directory didn't work.)" Do you mean all copying within that directory? Can you copy the file(s) locally and edit them, or do they still fail when accessed from the local desktop? – Robbie Crash Jul 23 '18 at 22:11
  • No, I cannot... all is explained, in the first five lines of the question, and that statement in itself, is pretty self explanatory. – tahwos Jul 24 '18 at 23:43

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.