1

With the Beaglebone Black and the latest Debian image from here, I cannot mount a USB hard drive. Both partitions on the hard drive are formatted as HFS+ (used for Time Machine backup and file storage). I run the command fdisk -l and can see the device as /dev/sda1. From there I try to mount the disk to a folder using sudo mount /dev/sda1 /media/usb

I get the error mount: unknown filesystem type 'hfsplus'

Using suggestions from similar questions, I've installed hfsplus, hfsprogs, hfsutils. I'm still getting the same error. I've read that the kernel may not have been compiled with support for this filetype.

However, at one point a couple of months ago on a Linux build, I plugged in the USB hard drive to the Beaglebone Black, and was able to access both partitions. The drive was automatically mounted, and I was given no issues about the HFS+ file format that the drive partitions are formatted to. I'm not sure where I was able to access the drive, but I believe it may have been in the /mnt or the /media directories.

What changed? I'm not sure what image was running on the Beaglebone Black before when everything just worked, but I'd like to figure it out. Is there a standard Debian (or other) image that automatically mounts the USB drive and handles the HFS+ file format?

  • (1) Please tell us exactly what commands you have tried and exactly what error messages you have gotten. (2) You mention Samba and ssh, and I can’t tell what you’re saying about which. … … … … … … … … … … … … … … … … … … … … Please do not respond in comments; edit your question to make it clearer and more complete. – Scott Jul 9 '18 at 0:17
  • Thanks for the suggestion. I've edited the question to hopefully make it more clear. – jekso Jul 9 '18 at 3:13
0

I reverted the Beaglebone Black to a much older image, specifically Debian 7.11 2016-06-15 4GB SD LXDE from the images page I linked to in my original question. Now when I plug in the USB hard drive, it is automatically mounted in /media and it apparently can read the HFS+ file format of the partitions.

I'm not sure at what point this functionality was lost, but I'd be interested to hear suggestions for solving this on the latest Debian Beaglebone Black images.

0

You could try different kernel versions:

Another option is to rebuild the BBB kernel:

  • This is the repository that has a branch per kernel version: https://github.com/RobertCNelson/bb-kernel/
  • You'd need to modify the config to enable the module you want.
  • Please note that you should do this on a PC, not the BBB. It would take forever and might fail if it runs out of RAM.

You could also post a request to the official BeagleBoard discussion group and request that HFS+ support be reenabled in default kernels.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.