8

I have a Logitech G302, a fine mouse. However, it glows blue, and the intensity increases and decreases. This can be distracting and I would like to turn off the lighting inside the mouse. How can I do this? The software that normally controls it is only available for OSX and Windows.

13
  • 1
    Which Linux distro are you using? You could try Piper mouse configuration utility. There are also a few other posts where people have used xbindkeys, which is for Arch, but other have had success using it on Ubuntu.
    – DrZoo
    Commented Jul 10, 2018 at 3:38
  • Hey, I'm using Linux Mint. I am trying to install Piper now (thanks for the rec!) but when i use Mason to build it i get the error "meson.build:1:0: ERROR: Compiler cc can not compile programs."
    – mc-lunar
    Commented Jul 10, 2018 at 3:57
  • Do you have gcc installed? Try gcc -v or which gcc If nothing shows up do sudo apt-get install gcc and then sudo apt-get install libgtk2.0-dev
    – DrZoo
    Commented Jul 10, 2018 at 4:06
  • I've got gcc installed already , the issue i guess is that meson is looking in the wrong place for it? Someone in an IRC told me to apt-get install build-essential which works - until meson tells me that "native dependency libudev not found".
    – mc-lunar
    Commented Jul 10, 2018 at 4:21
  • libudev can be installed by sudo apt-get install libudev-dev libsystemd-dev .... I hate configuring compilers lol.
    – DrZoo
    Commented Jul 10, 2018 at 4:24

3 Answers 3

13

Since most Logitech gaming mice store the mouse profile and settings on the mouse, you can use a Windows or Mac OS to install the Logitech Gaming Software and configure your mouse how you want it. Once you're done, you can unplug the mouse and plug it into the Linux system, and it will still have the same desired behavior.

If you only have access to a Linux OS and you want to change your mouse configuration, you can try to download and install Piper mouse configuration utility.

5
  • I was able to turn off the LEDs of my G703 with Piper on Ubuntu.
    – Philipp
    Commented Feb 10, 2020 at 8:44
  • 1
    The G102 and G203 mice can be set using Onboard Memory Manager (Windows), and the setting then also works on Linux.
    – Gander
    Commented Dec 3, 2020 at 19:57
  • Configuring under macOS and plugging in under Linux made my G703 turn on the lights again. Disabling them with Piper worked though.
    – slhck
    Commented Jul 9, 2021 at 11:09
  • piper and its ratbagd friend were hellish to meson build and install, to finally not work. I followed your advice and used a Mac to change the mouse config using G Hub, and save "on board". That config remained on Linux, thanks.
    – Déjà vu
    Commented Feb 27, 2022 at 13:45
  • this one is pretty good (does not save), and this one about piper & ratbagd is made by someone who knows what they talk about.
    – Déjà vu
    Commented Feb 28, 2022 at 13:45
5

I couldn't get Piper installed. However, this worked for me, for a G102 Mouse:

git clone https://github.com/smasty/g203-led.git
cd g203-led
virtualenv ./env
env/bin/pip install -r requirements.txt
sudo ./g203-led.py solid 000000

I presume it'll work for the G203, since that's what it's designed for, and presumably it'll work for other G-series mice, including the G302.

1
  • For lightsync mice, you just need to put "lightsync" in the command like this sudo ./g203-led.py lightsync solid 000000 which is what is stated in the docs in the git repo.
    – ZachS
    Commented May 24, 2023 at 4:16
-1

https://github.com/green5/g102-dpi-color
Logitech G102 dpi to mouse color mapper

2
  • 4
    Link-only answers are not considered as real answers here: please explain how the page you linked to solves the problem posed in the question. Commented Jul 10, 2022 at 18:17
  • 1
    Presumably, you are suggesting that, as the G203 code from this answer worked on a G102 mouse - and maybe for a G302 mouse - then, this code may also work for both G203 and G302 mice? If so, then please edit and explicity add that to your answer, rather than letting readers having to try and deduce that themselves... Commented Jul 11, 2022 at 13:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .