0

I'm going crazy with this. PC1 is Win 10 Pro, has shares that are seen by other computers on network. This computer doesn't see any shared folder or even computer, but sees media devices, other devices, and network printers and can access to them all these devices.

All other computers on the network see each other, see the nas, see the network printer and see the PC1 shares. The only one with issues is PC1.

When, from PC1, I try to connect to other computer or shares using \\ipaddress, after a few second I get the error "Unspecified Error 0x80004005"

what I have tried so far:

  • Disabled firewall on PC1, nothing changed.
  • Checked sharing options, everything is fine, network discovery is on, file and printer sharing is on, password protection is off.
  • I have checked HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order - Provider Order and HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider\HWOrder - Provider Order they are both with the correct value of "RDPNP,LanmanWorkstation"
  • Checked that "client for windows" is installed on my network adapter
  • Ping to ip address works fine, net use to same ip address gives error 67 "network name cannot be found"
  • Checked Control Panel -> Administrative Tools -> Local Security Policy Under Security Settings -> Local Policies -> Security Options Set "Microsoft network client: Digitally sign communications (always)" to "Disabled" was already disabled
  • Checked that both services are active: Function Discovery Provider Host, Function Discovery Resource Publication
  • Tried this, no changes: 1) run cmd as admin 2) sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi 3) sc.exe config mrxsmb20 start= disabled 4) restart

One strange thing: Microsoft Network Adapter Multiplexor protocol is disabled on the adapter. I click to enabled it, when press OK it say "you will disable this service". I reopen the window, the service is disabled.

Anything else I can try to make it work again?

EDIT: I looked to the other possible duplicate question.

  • My network is set up as private, as it should be.
  • SMB 1.0 is present on my windows component setup
  • I get the same error not just with any local ip address, but also with \\localhost and even \\127.0.0.1

System version is Windows 10 Pro Version 1803 Build 17134.112

If I use Filezilla to connect to network nas (that has an ftp server enabled) I can connect succesfully and upload/download files. I can't access it with windows network explorer.

1

Open the command prompt as Administrator and run each of the following commands:

netsh winsock reset
netsh int ip reset
ipconfig /release
ipconfig /renew
ipconfig /flushdns
0

I fixed the issue. Double checking every service I noticed that workstation service was stopped. When starting it, I got the error

"Error 1075: The dependency service does not exist or has been marked for deletion"

Getting into regedit and deleting the relative dependOn key fixed the issue for me.

  • I am glad to hear that you resolved the problem, but based upon your final solution it sounds like something "broke" within your operating system based upon the extensive modifications that were made during troubleshooting. Without those additional elements in the equation, this is the only time I have ever seen the SMBv1 install not work under similar circumstances. – Run5k Jul 11 '18 at 15:57
  • @Run5k Yeah I noticed that I had a very rare case of malfunction. I hope that my struggle will be of help to other should this issue arise to more people in the future – Terix Jul 12 '18 at 20:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.