1

I've just installed Ubuntu 18.04 LTS on a UEFI laptop also running Windows 10 and, no matter what I try, every time I boot I get the Grub bash-like command line (grub>). Running set shows me that, each time I boot, root and prefix are set to (hd0,gpt1) and (hd0,gpt1)/boot/grub when they should both be on (hd0,gpt8). So I set these to the correct values, run normal, and I get to the Grub bootloader from which I can boot to Ubuntu or Windows - all fine.

BUT having got to Ubuntu, update-grub and grub-install don't fix the problem permanently. The root and prefix revert to (hd0,gpt1) on the next reboot. I have so far tried:

  • update-grub, grub-install, initramfs -v -u
  • Running boot-repair (trying purge, nodmraid)
  • Running Super Grub2 Disk on USB (which finds the .cfg files)
  • Reinstalling Ubuntu (twice)
  • Running Super Grub2 Disk by copying the .EFI into the boot partition and updating the BCD store with bcdedit in PowerShell

Interestingly when I tried to run Super Grub2 Disk from the EFI it ran into the same problem and only showed the Grub2 bash command line. I'd just like to be able to get to the grub menu without having to go through setting the prefix and root each time. I'd be really grateful for any help because I've been bashing my head against the wall for about two days!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.