1

After installing a game from Blizzard(Diablo 2) and playing it for a while, I shut down my laptop and opened it again the next morning. That's when my laptop(Lenovo T520) was booted to a black screen with my mouse cursor being able to move. At that stage, I couldn't bring up anything, not even task manager either(ctrl-alt-delete).

I plugged in my bootable Windows 7 USB drive and tried to repair from there. The System Recovery Options found the repair details:

The following startup option will be repaired: Name: {bootmgr} Identifier: {a whole bunch of letters and numbers}

The following staratup options will be added: Name: Windows 7 Ultimate (recovered) Path: Windows Windows Device Partition=D: (122002 MB)

Name: Windows Recovery Environment (recovered) Path: Recovery\numbers and letters\Winre.wim Windows Device Partition=D: (122002 MB)

A copy of the current boot configuration data will be saved as: C:\Boot\BCD.Backup0003

However it didn't work because after pressing ok to repair and restart, it gave an error:

Failed to save startup options.

In the order of sequences that I have tried afterwards:

  1. [unsuccessful] Safe mode/ Safe mode with cmd/ Last known working/ Low resolution -All of these options led me to the same black screen with movable mouse cursor

  2. [successful] System Recovery Options CMD - bootrec /fixmbr and /fixboot -Both were successful but after restarting laptop, bootmgr was missing.

3 [unsuccessful] Again, CMD - bootrec /rebuildbcd -Windows installations identified: [1] D:\Windows - error when tried to add installation to boot list: The requested system device cannot be found.

  1. [successful] CMD - bcdboot D:\Windows /s C: -I was able to fix the bootmgr error with this, but now I am back to my original problem, nothing has changed, safe mode doesn't work either.

Additional information:

I have tried switching USB slots to repair but didn't work. I have checked diskpart: Volume 1 C NTFS Partition 100 MB Volume 2 D NTFS Partition 119 GB (SSD)

I don't know what volume 1 is for but I read a comment saying it's the bootmgr sector? I've tried activating both of these partitions while using bootrec but same result. I am still debating on whether I should just get an adapter/enclosure and retrieve as many files as I can from my SSD but it will be a long process. Please feel free for any advice/feedback/comments, I am desperately looking for any solution.

edit 1: I have just tried sfc /scannow /offbootdir=D:\ /offwindir=D:\windows but failed with the error message: Windows Resource Protection could not perform the requested operation.

  • @PimpJuiceIT Thank you! I had just tried one of the instructions but still failed, nonetheless, that's one 1 more mystery solved! – guest12345 Jul 11 '18 at 16:59
  • @PimpJuiceIT It doesn't get to the black screen now, my bootmgr is messed up so I'm always at the file: Boot\BCD screen with the error message: An error occured while attempting to read the boot configuration data. – guest12345 Jul 11 '18 at 18:43
  • Okay, check out and read over this post & check out the linked posts it refers to as well superuser.com/questions/626228/… Also this post talks about the steps to easily rebuild a BCD from one of the answers.... superuser.com/questions/637011/…. Perhaps just a process of elimination so keep trying and certainly you'll find a solution assuming the drive isn't toast but hopefully not & just a corrupt BCD. This may work since the bcd commands you've already tried didn't. – Pimp Juice IT Jul 11 '18 at 19:31
  • @PimpJuiceIT Thanks!! Will report back if anything – guest12345 Jul 11 '18 at 23:18
  • Enter the bios and restore default settings. – Moab Jul 12 '18 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.