Xenu Link Sleuth has worked for years and two weeks ago it failed to connect to my site (https://www.horsekeeping.com). No changes made to my computer at that time. Xenu can connect to every other site I've tried. My browsers, email and ftp are all connecting to my site. Uninstalled and installed Xenu several times. Disabled firewalls and anti-virus, flushed DNS. Xenu consistently gives error: "busy" "no connection", when I try to crawl my own site. I'm on Hughes latest satellite and I have another similar computer on same network through a TP-Link router and Xenu will connect to my site on that computer. I discussed this problem with Xenu's developer and he says it's not a problem with the program and I agree - I don't think it's the program or the router. What on my computer would prevent Xenu from connecting only to my site?

  • So, it's a problem limited to one computer. Uninstalling Xenu may not be removing all of its stored components, and one of these may be corrupt. You may wish to ask the developer for a manual uninstall process that fully removes all components, and try that. Jul 11 '18 at 17:54
  • Thanks for your reply. I used Xenu's uninstall file and also ran Revo Uninstaller to clean out remaining registry components (several times for both).
    – klimshelf
    Jul 11 '18 at 18:06
  • The former may be inaccurate, and Revo, for all its brilliance, is not a guarantee. You should ask the dev for this. At the very least they should want to know the cause of this bug to prevent it from occurring elsewhere. Jul 11 '18 at 18:08
  • Followed dev's instructions for manual uninstall. Rebooted. Installed Xenu and set it to crawl my site: "busy" "no connection".
    – klimshelf
    Jul 11 '18 at 23:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.