1

Operating System: Windows 7 Home Premium

The title pretty much says it all, I'm trying to format this laptop of mine and I can't do so, because windows is booting normally When I click on USB option to boot from. I've tried several USBs (both USB 2.0 and USB 3.0), all are working on other PCs, burned windows on them using Rufus. I unplugged the laptop from electricity completely, tried again, nothing worked, tried to play with Bios options, there isn't much to do there anyways, I'll attach some screenshots of the laptop specs and its BIOS version etc.

System Information

Boot Manager

BIOS System Configuration

Any help's appreciated, thank y'all in advance!

  • You failed to indicate which version of Windows you are running. Please edit your question and include this vital information. – Ramhound Jul 11 '18 at 21:07
  • Oh my bad didn't think it'd matter, done. – Zayd Jul 12 '18 at 14:48
  • Windows 7 does not support being installed from USB 3.0 unless you add the necessary drivers to the ISO. How that is accomplished is well documented – Ramhound Jul 12 '18 at 14:55
  • Tried using USB 2.0, led to no avail.. – Zayd Jul 12 '18 at 15:04
  • Make and specific model of PC??? – Moab Jul 12 '18 at 20:19
-2

Some computers do not detect any USB's existence until after Windows starts. There is usually a toggle for this in the BIOS but not always.

  • 1
    Well.. such thing isn't found in my case, and apparently it's detecting my USB as it's displayed in the boot manager.. right? – Zayd Jul 12 '18 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.