0

Holy cow, here we go.

So, initially I had a dual boot with Kali Linux installed on a USB drive and Windows 10 installed on my hard drive and GRUB handling the boot options when the PC started up. Any time the USB was not inserted and I would try to start up the PC it would enter grub rescue and all I would have to do is insert the usb and restart.

Recently, my dog hopped up on my bed where I had the PC and broke my USB and now can't get passed grub rescue... hilarious right. Anyways, I've tried multiple options like using boot tools like hirens boot CD. I've tried the set boot/set prefix but keep running into issues.

HBCD

The issue here is that grub is supposed to have it's own fat32 partition but when I look at my options they're just my plain old c:\, the recovery partition and (blank) so nothing to be deleted.

Set boot/Set prefix

Here I have no idea what I'm doing just plain old guessing and following tutorials but the way I'm going about it is

error: no such device: 0d61c783-a8f9-more numbers and letters
error: unknown filesystem.
Entering rescue mode...
grub rescue> ls 
(hd0) (hd0,msdos3) (hd0,msdos2) (hd0,msdos1) (hd1) (hd1,msdos1)

---straight up guessing its (hd0,msdos1)---

grub rescue> set boot=(hd0,msdos1)
grub rescue> set prefix=(hd0,msdos1)
grub rescue> insmod normal
error: unknown filesystem

I try it with all the others and same problem.

I'm currently trying to fix a Lenovo Thinkpad x220 model: 4293af7 Cheap tech companies decided it'd be a good idea to deny these guys a CDROM drive. The goal is here to just get rid of grub and boot directly into windows 10 every time I start. I'm decently tech savvy but know nothing in this area. Got kali to learn about wireless penetration and didn't want to create another partition when I had a 32gb USB3 and only 120gb HDD.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.