1

This question already has an answer here:

My system is currently very slow, and I'm fishing for reasons why this might be..

System is : W10x64 Pro, i5-4460 CPU @3.2GHz, 8GB PC3-12800 @ 1600MHz, 500GB SATA HDD.

Disk C: has less than 10% free space, and from what I see in Task Manager, disk usage is my main problem. From time to time the computer freezes, and I have to wait 10-15 minutes for it to release.

Just now I noticed I have 16GB of committed memory, I have no idea why. Might it be that the system is forced to write data on the HDD all the time and this is why it is so slow ?

Image from Task Manager :

enter image description here

EDIT. My Paging file is 8GB which explains the committed memory size.

enter image description here

Should I disable it and see if the RAM is enough for my usage .. I need a solution on how to get the system to work normally.

marked as duplicate by Ramhound, music2myear, bertieb, Pimp Juice IT, phuclv Jul 31 '18 at 11:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @Yorik I had just found out my pagefile was 8GB when you posted. I will edit the question to reflect that. But i still have the problem of how to speed up the system – alfred Jul 12 '18 at 16:13
  • You could try manually defining the page file size to 1 GB. – Norm Jul 12 '18 at 17:14
  • The commit charge is 2.2 GB with a commit limit of 15.9 GB. This is not high. The size of the pagefile is 8 GB but that tells you nothing of how much is in use. Considering the low commit charge and memory usage I would guess not much. – LMiller7 Jul 12 '18 at 18:50
  • @LMiller7 I also thought about that. For the moment I disabled paging file to see if windows freezes again, but the startup is still slow. I only recently added the second 4GB RAM, so the paging file might have been used a lot more previously, and maybe this has caused some damage either to the HDD (only 10% free), or Windows – alfred Jul 13 '18 at 13:51
  • 1
    There is no evidence here to suggest that the pagefile has anything to do with your problem. – LMiller7 Jul 13 '18 at 14:41
3

You do not have 16 GB of committed memory. Your task manager screen snap shows that you have 2.2 GB of committed memory, aka "commit charge", with a commit limit of 16 GB.

Committed memory is virtual address space, specifically process-private virtual address space, and it is pageable. So n GB of commit charge is not necessarily using n GB of RAM. And on the other hand, there are other uses of RAM besides committed memory.

See the numbers on your first Task Manager screen snapshot under "Committed"? The first shows how much is currently committed (the "commit charge") and the second shows the commit limit. (Running into the commit limit brings you the "Windows is low on memory" pop-up.)

The graph on the memory page shows physical (RAM) memory usage and it shows only 30% of RAM in use. So disabling your page file will not address your performance problems.

Committed memory is created when processes allocate it. You don't really have a problem with your commit charge, but for reference, I'll add: Each process's contribution to this is shown in TM's "Details" tab, "Commit size" column (which is not displayed by default; you'll likely have to add it). The paged and nonpaged pool also are part of the system-wide commit charge.

You mention that another view of Task Manager (which we can't see) seems to show that your disk 0 is busy a high percentage of the time. Try using the Disk tab in Resource Monitor to see what's accessing the disk so much.

btw, an often-overlooked cause of slow disk activity is disk errors, which result in retries. Check the event log for this.

Not the answer you're looking for? Browse other questions tagged or ask your own question.