I have a 2017 MacBook Pro (15") and have put Ubuntu 18.04 on it. I've managed to get the drivers for keyboard and the trackpad working, but so far, I am unable to connect to Wi-Fi.

But I am able to see Wi-Fi networks, and I can attempt to connect to the (type in password etc. - yes, the password is correct), but the network utility just spins for a minute, and then asks for the password again.

I am happy to provide whatever details you need!

  • Update: I am able to connect to my phone's tethering, when I turn off authentication completely (no wpa2...).
    – Silvertail
    Jul 14, 2018 at 2:10

1 Answer 1


Turns out the Wi-Fi module was trying to randomize its MAC address via NetworkManager.

The standard fix for this did not work, but I was able to get it to work by going into /etc/NetworkManager/system-connections and editing my specific connection.

I added mac-address-randomization=0, tried connecting to the network again, and everything worked!

  • Great self-answered question. But why was your Wi-Fi MAC address being randomized? Was that intentional? Jul 14, 2018 at 16:16
  • No, this is apparently automatic with NetworkManager. Originally it was meant as a security feature by the devs.
    – Silvertail
    Jul 15, 2018 at 1:08
  • Ahhh! That honestly sounds excessively ridiculous for a default feature. Reading up on it here it seems more a headache presented as a “solution” more than anything else. Jul 15, 2018 at 1:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.