I bought a 6TB (5.45TB usable) to transfer my 3TB drive.

I used robocopy source destination /MIR /R:0 /W:0 /xo

Robocopy reports that 2.228TB were copied, but I only have 1.18TB left available out of the 5.45TB.

My 3TB is drive is NTFS, and my 6TB is exFAT, but I don't tink that it matters.

I tried “Disk cleanup” and “Clean up system files” but both report nothing to clean.

Why am I missing so much space and how to retrieve it?


2 Answers 2


"My 3TB is drive is NTFS, and my 6TB is exFAT, but I don't tink that it matters"

Yes, it matters.

Your allocation size is critical here. Change your file system to NTFS or exFat, both need to match. Or, set the unit size as small as possible. I suspect you left the settings on default. Otherwise, each file, even the smallest file(e.g. 1kb) will be 4096KB once transfered. If you were to do the math, you would get the amount of gigs shown in your log report.

In conclusion, the easiest solution is to match file system format. Both NTFS or both exFAT.

  • 1
    No, they don't need to "match." And setting the allocation unit size "as small as possible" on NTFS is incorrect. Set it to the NTFS default, which is 4K. Your smallest files will only take 1KB. Commented Jul 15, 2018 at 2:21
  • if filesystems need to match in order to copy then how on earth you can copy between FAT32 and NTFS? And allocation unit should be left as 4KB, or file access will be slow for large files, unless you have mainly very small files, but it's very unlikely that the OP has TBs of tiny files
    – phuclv
    Commented Jul 15, 2018 at 3:57
  • I believe I was clear. You're taking a different view. What I mentioned is that If you don't want discrepancies at all after copying files between different file systems(e.g. NTFS, FAT32, or exFAT), your best option is to match file systems before copying. On the other hand, if you want precision and want to keep file systems different, you need to be very meticulous with unit size and its settings.
    – Full Array
    Commented Jul 17, 2018 at 21:05

I did tried the 128kb AUS, but it still took an extra Tb, I guess I have to many small files.

The simpler solution was to format my 6tb drive to NTFS, recopy everything and the transfered size was the same as the original.

Thanks for your help

  • I think I answered your question with high precision, please mark my answer as correct if you think my answer helped you.
    – Full Array
    Commented Jul 19, 2018 at 17:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .