Domain Controller 1 = Windows 2008 R2

Domain Controller 1 = Windows 2003 R2

  • Domain Name = MYCOMPANY (Single Label Domain)
  • Functional Level > Windows Server 2003

Clients: Mix of Windows 7 Pro / Windows 10 > 100 qty

Recently we acquired licenses for Win 10 Pro (Downloaded Win 10 ver 1803). When we try to join W10 to domain, it gives error

Ac active directory domain controller (AD DC) for the domain "MYCOMPANY" coould not be contacted. 
Ensure that the domain name is typed correctly.

Previous version of windows 10 are joined to domain properly. but only this new version 1803 is not able to join domain.

I can ping domain controller names via effected clients. nslookup working ok.

How can I track the issue? kindly advise.

  • Please clarify your specific problem or add additional details to highlight exactly what you need. You have several statements that appear to be incorrect from a technical point of view. I don't want to make an incorrect assumption. Can you clarify your question?
    – Ramhound
    Jul 16, 2018 at 14:12
  • 2
    It seems a known issue on Windows 10v1803. See this original thread: social.technet.microsoft.com/Forums/en-US/…
    – Waka
    Jul 18, 2018 at 9:45
  • REGEDIT solved the issue Jul 19, 2018 at 10:41
  • 1. Start, Run, write regedit,ENTER. • Lookup this subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters • Locate AllowSingleLabelDnsDomain. If the key AllowSingleLabelDnsDomain does not exist: • Edit, New, DWORD. • Write AllowSingleLabelDnsDomain as key name, and ENTER. • Double click AllowSingleLabelDnsDomain. • Set the Value to 1. 2. Exit regedit 3. Try to join the domain Jul 19, 2018 at 10:41

1 Answer 1


I was able to join WINS, Single Label, NT4 style domain after i reinstalled Windows 10 from old 1511 disk. Update 1803 is installing back now, and most likely domain will still work after that.

All other methods was ineffective, including: changing various registry options(like AllowSingleLabelDnsDomain, DNSNameResolutionRequired, DomainCompatibilityMode), changing network type, adding domain name to hosts file, updating or resetting windows.

Before i had same error and error details was:

The error was: "DNS name does not exist."
(error code 0x0000232B RCODE_NAME_ERROR)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .