I have a DNS server set up on one of my machines using BIND 9.7 Everything works fine with it. On my Windows 7 desktop, I have statically-assigned all network values. I have one DNS server set -- my DNS server. On my desktop,

 I can ping a third machine by IP fine.
 I can nslookup the hostname of the third machine fine.
 When I ping the hostname, it says it cannot find the host.


C:\Users\James>nslookup icecream
Server:  cake.my.domain
Address:  xxx.xxx.6.3

Name:    icecream.my.domain
Address:  xxx.xxx.6.9

C:\Users\James>ping xxx.xxx.6.9

Pinging xxx.xxx.6.9 with 32 bytes of data:
Reply from xxx.xxx.6.9: bytes=32 time<1ms TTL=255
Reply from xxx.xxx.6.9: bytes=32 time<1ms TTL=255
Reply from xxx.xxx.6.9: bytes=32 time<1ms TTL=255
Reply from xxx.xxx.6.9: bytes=32 time<1ms TTL=255

Ping statistics for xxx.xxx.6.9:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\Users\James>ping icecream
Ping request could not find host icecream. Please check the name and try again.

I have also specified the search domain as my.domain

  • xxx.xxx and my.domain substituted for security

Why can I not ping by hostname? I also can not ping using the FQDN. The problem is that this problem is shared by all applications that resolve hostnames. I cannot use PuTTY to SSH to my machines by hostname; only by IP

  • I'm in a similar setup, and forgot at first that I can (as you should be able to) use icecream.local. This works for me because I don't have a domain, but I do have a local DNS server that has internet and intranet name services.
    – user68988
    Feb 24, 2011 at 15:17

6 Answers 6


You could try editing your hosts file. Put there the hostnames and ip-adresses of your other machines. If thats not working try this: Your Router should be able to handle dns-tables for itself. Try to temporarly shut down your dns-server and clear all dns caches on all machines. Then restart your router and try it again.

  • 2
    Your post gave me an idea. I tried ipconfig /flushdns and it started working again. It doesnt make sense though because it was working before then it just stopped. check&+1 for helping.
    – jamesbtate
    Apr 23, 2010 at 16:43
  • @Puddingfox Have you found any real cause? I have posted essentially the same question for a Windows XP SP3 computer, with the same workaround.
    – Mark Hurd
    Jun 13, 2010 at 5:14
  • 4
    If you put the names into the hosts file, what is the point of having DNS?
    – vonbrand
    Feb 10, 2013 at 4:19
  • You can spend days working out why say a Windows 10 machine across a VPN connection can't resolve a host name. Life's too short for that sometimes so I recommend using a host file. Aug 29, 2016 at 9:05

I faced the same problem in my network. When you use this command:

ping icecream

It uses WINS server since you have used icecream not icecream.my.domain.

When looking for such words, Windows looks for NETBIOS names, but when you look for complete domain records, it will look in the DNS server. You can use one of the solutions below:

  1. Make sure you have correct records for that station in your WINS server.
  2. Use the complete domain name instead of using the host file. E.g. icecream.my.domain
  • 2
    Ping uses the normal Windows name resolution methods. Which means it starts out by checking the resolver cache, the local hosts files, the DNS servers, and eventually will resort to sending out a NetBIOS name query to everything using NetBIOS on the same subnet.
    – mazianni
    Feb 24, 2011 at 15:32

You don't have DNS suffixes configured. Either configure them, or use FQDN like this and it should work:

ping icecream.my.domain

I'm looking for a permanent solution to this problem. I don't just have a problem with ping icecream, but also ping icecream.my.domain. It doesn't happen all the time, just randomly on one computer. ipconfig /flushdns fixes it sometimes and rebooting work as well, but it's not a permanent solution.

I just tried this:

Based on this:

  • If you have a new question you should probably delete this answer and ask a new question instead, linking back here.
    – slhck
    Nov 22, 2011 at 22:12
  • I don't have a new question. I have this SAME problem. I'm answering with a possible solution.
    – bendiy
    Nov 22, 2011 at 22:14
  • Worked for me :)
    – Zsub
    Nov 28, 2011 at 14:14

To disable this behaviour, disable Negative Caching by setting the value of NegativeCacheTime to 0 at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ Dnscache\Parameter


Check for firewall settings in your Windows 7 machine. By default, Windows 7 added to a domain turns on the firewall. You can also make a rule to open ICMP in firewall. This will allow these packets to reach your machine and you'd be able to ping it.

  • The op could ping the machine by ip just fine.
    – Jason C
    Jul 17, 2014 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.