5

Basically, this: How to remove all the vEthernet (Default Switch) once and for all?

Except, I removed hyperV and the Containers feature, and all that happened was that the NIC reported as disabled. But it was still there. Then I reinstalled hyperV and it created a second one. Removing HyperV disabled, but did not remove the second one.

I removed it from the registry manually (see third post here: https://social.technet.microsoft.com/Forums/en-US/7f18af6f-4f6b-40ac-94bc-4be32e850fb1/vethernet-default-switch?forum=win10itpronetworking) and that made exactly no difference.

So my question is, short of resetting my laptop, how can I make this stupid thing go away? It's screwing up my networking (auto-switch between WiFi and Ethernet doesn't work anymore)

Edit: for clarification, my end goal, here, is to have (a) Hyper-V removed (uninstalled) and (b) remove the (now unnecessary and unwanted) Hyper-V switches that remained after Hyper-V was uninstalled.

1
  • did you also check the window services? in my cases after hyper-v removal all services were still there and one was running. i hav the same problem and didn't found a solution yet (all answers not working for me) – dermoritz Oct 22 '20 at 8:45
4
  1. Use the Hyper-V management console or Device Manager aka. devmgmt.msc to remove virtual NIC. Do not remove NIC via registries

  2. You remove virtual switch via PowerShell like it's specified here: https://www.starwindsoftware.com/blog/basic-hyper-v-virtual-nic-management

  3. Also as a workaround, you can try these steps. https://social.technet.microsoft.com/Forums/windows/en-US/e49df568-4f4c-47b7-b30c-952d1e26ca58/cant-remove-failed-virtual-switch-from-hypervs-virtual-switch-manager

3
  • 2
    As of Windows 10 2004, Hyper-V management console does not allow to remove the "default switch", only user generated virtual adapters. – Tyler Jul 12 '20 at 5:49
  • 1
    Using powershell to remove "default switch" via [Remove-VMSwitch -Name "Default Switch"] it returns an error "The automatic Internet Connection Sharing switch cannot be modified." – Tyler Jul 12 '20 at 5:56
  • don't work for me - all adapters always reapear after reboot – dermoritz Oct 22 '20 at 8:34
1

Despite the down votes, I found a definitive solution. [Note response by Microsoft] My solution works, even with Hyper-V enabled. Many of us don't want to disable Hyper-V security, and nothing else here worked for me on Windows 10 2004, everything is replaced on reboot, even netbios settings which increase attack surface, and its a pain to configure potentially hundreds of adapters every single time. Even automating with Nvspbind all settings revert on reboot. One way to disable these adapters literally ONCE AND FOR ALL is to disable DNScache aka Dns Client service and use a third-party DNS service such as Acrylic , or SimpleDNSCrypt. Be sure to comb through Acrylics configuration with a fine toothed comb because initially your default DNS provider will automatically be set to google or cloudflare. Then point acrylic to your router IP, or preferred DNS server, and set all your adapters DNS settings to 127.0.0.1.

You must disable DNSCache with regedit, here:

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dnscache

Set start to 4, and reboot.

The only minor caveat is you may see a single adapter constantly and briefly appearing and disappearing under Control Panel\Network and Internet\Network Connections and your device manager window will constantly refresh each time it attempts to install adapters. This problem appears to have went away for me after I enabled DNSCache (which was already disabled before I initially started using Hyper-V), then disabled it again. Another caveat is that initially loading the windows store you will get an error, unless you have previously opened the store with DNScache enabled. After that the store will work indefinitely unless you reset it. Not a big price to pay given how annoying this is, this actually works.

2
  • If you just want to disable the NIC(s) permanately, you can use a scheduled task, as noted in the final comment here: social.technet.microsoft.com/Forums/en-US/… – Tyler Jul 22 '20 at 14:24
  • this is indeed the only solution working, but i need at least one adapter for wsl. I only want to get rid of 4 abandoned adapters that occupy many dynamic ports. After reenabling dns cache all are back :-(. – dermoritz Oct 22 '20 at 8:31
0

I've solved it, I think. I deleted all entries under these two keys:

HKLM\SYSTEM\CurrentControlSet\Services\VMSMP\Parameters\NicList HKLM\SYSTEM\CurrentControlSet\Services\VMSMP\Parameters\SwitchList

And rebooted. I should note that this is obviously the nuclear option.

Edit: As mentioned in the comments, device manager probably would have worked too, had I remembered that device manager was a thing.

4
  • 3
    NEVER delete NIC registries. Use Hyper-V management console or Device Manager aka. devmgmt.msc to remove virtual NIC. Also you don't have to remove default switch, it's 'default', provide internet access in VMs. – Biswapriyo Jul 18 '18 at 20:40
  • 2
    Except, as I said, I completely uninstalled hyperv since I'm not using it (I'll clarify above). There aren't any VMs to provide internet to. – Chris Jul 18 '18 at 21:57
  • 2
    Also, you can't to my knowledge remove the default switch using the Hyper-V management console. And only one of the two switches was actually recognized by Hyper-V anyway. Though I'll admit, I regrettably completely forgot device manager was a thing. – Chris Jul 18 '18 at 22:03
  • 1
    not working for me - all adapters reappear after reboot – dermoritz Oct 22 '20 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.