0

I have a setup of a tower PC and a Notebook both using Windows 10 and both connected via cable to my router. Previously they were in the same home group and thus able to find each other in the Explorer.

But now that the last Windows 10 update has removed the home groups neither of them can find the other. I have checked the network detection and file- and printer sharing options and they're all set up properly, meaning private, guest and public are both active. Sharing public folders in the all networks section is disabled, though, but that shouldn't cause trouble.

Now, I think the problem is that both of the PCs are contained in their own network. In the ethernet menu item in the settings I can see that my notebook is part of the Todkaeppchen network, while my tower PC is in the Network 2. Neither can find any other network and in the control panel I only have the option to create a new network, not join an existing one. So, how can I tell my tower PC to join the Todkaeppchen network of my notebook?

I should note that I also have a WLAN network set up named Todkaeppchen, which the notebook can connect to but not the tower. However, as it is set in the Ethernet section I don't think this is the root of the problem. Nothing changes whether my notebook is connected to the WLAN with the same name or not.

  • 1
    We have helped a few people faced with this same scenario since HomeGroups were eliminated. Take a look at this answer and see if it helps. The most important part is that they belong to the same WORKGROUP by name. – Run5k Jul 18 '18 at 23:48
  • It has been several days since we heard from you. Have you made any progress? – Run5k Jul 22 '18 at 16:32
  • I'm sorry I haven't come back to this topic yet. I did not find the time to try the suggestions posted here but I will update as soon as I found the time (which might take another week, though). – Otto Abnormalverbraucher Jul 23 '18 at 9:41
0

Now, I think the problem is that both of the PCs are contained in their own network. In the ethernet menu item in the settings I can see that my notebook is part of the Todkaeppchen network, while my tower PC is in the Network 2. Neither can find any other network and in the control panel I only have the option to create a new network, not join an existing one. So, how can I tell my tower PC to join the Todkaeppchen network of my notebook?

Just to clarify one thing: Without HomeGroup, there is no HomeGroup-like "network" that hosts must explicitly join or leave in order to communicate. The network name that you describe is simply for display purposes.

The network detection is used by Windows to automatically switch between "Public" and "Private" modes of the firewall, depending on the location. But it doesn't affect anything else. As long as both computers' firewall mode permits file sharing, it doesn't matter whether the names match or not.

You might be thinking of NetBIOS "workgroup" names, which do need to match in order for network discovery to work. The workgroup name can be configured in Control Panel → System.

(I'm not sure whether this affects the newer WS-Discovery protocol in any way. I believe it simply works according to IP subnet boundaries, and "sees" all computers within the same subnet. Modern Windows versions run both protocols side-by-side, or in fact disable NetBIOS completely due to its SMBv1 dependency, so I'm actually surprised the workgroup name is still an issue.)

The "IP subnet" part shouldn't be overlooked. Both discovery protocols work using multicast, so if you have "stacked routers" (each creating its own subnet), the discovery packets won't be able to reach from one subnet to another.


As an aside, automatic discovery is not strictly required for sharing files; it just adds convenience features. My suggestion would be to troubleshoot this incrementally:

  1. First get the computers to successfully ping each other, either by IP address or by name.
  2. Then get the computers to manually access each other's files via \\ip.addr.ess paths.
  3. Finally, try to get automatic discovery working.
| improve this answer | |
  • Thank you so far. I can ping and access the computers via \\ ... but how do I get 3. working? – Otto Abnormalverbraucher Oct 9 '18 at 18:37
0

In the end, after a while of some more googling, I found the problem was a deactivated service called "Function Discovery Resource Publication". After activating that my computers were able to find each other again. Thanks for the suggestions and help, though.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.