0

I've added some macros to a custom group in the ribbon. It is all fine, and works as expected. However, I've noticed if I go back in to customize that group, I end up with triplicated macros and I'm not sure why.

  1. Add the custom group, and the four macros
    enter image description here

  2. Check that it works correctly in Ribbon (it does)
    enter image description here

BUT!

  1. If I go back to the group, to add (or remove) a macro, suddenly the macros were all triplicated for some reason.

enter image description here

I did nothing else except add the macros to the group, click "Ok", then go back to customize the group. Any ideas what might be causing this to occur?

Edit: MS Office 365, Excel Version 1806 (Build 10228.20104 Click-to-Run), Windows 7 Pro.

  • What is the version of Excel (2016, 2013, etc)? If it is 2016, what is the version and build number (found on File>Account>About)? – Rich Michaels Jul 19 '18 at 15:09
  • @RichMichaels - D'oh, of course! Edited in to OP at the end. – BruceWayne Jul 19 '18 at 15:22
  • I can reproduce the same weird behavior. Interestingly, no additional entries are made on the ribbon, only the original three remain. You can also delete the extras but they do a Terminator on you and Come Back. The good news is the original three also continue to work. I'll see if I can get someone at MS to look into this. – Rich Michaels Jul 20 '18 at 1:26
  • 1
    I have reported this to Microsoft as a bug. If I learn of a resolution I report back, or maybe someone from MS will reply directly. – Rich Michaels Jul 20 '18 at 2:06
  • @RichMichaels wow, thanks! I was wondering if it was just me or not. For what it's worth I don't recall it doing this on previous versions. – BruceWayne Jul 20 '18 at 2:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.