1

This question already has an answer here:

I'm required to install some software on my work laptop. It's running Windows 10 Enterprise. It failed, telling me that I need to have the .NET Framework 3.5 installed. I've tried, unsuccessfully, to install .NET 3.5 both by going to Microsoft's website and also by going through Turn Windows Features on and off. Neither worked. I've looked here on Superuser, but couldn't find anything the discussed error 0x800F0954. Found other errors, but not 0x800F0954, so I don't believe this is a duplicate. Given this, then how to I resolve this problem? Here's a picture of the error:

enter image description here

marked as duplicate by Moab, music2myear, Ramhound, Pimp Juice IT, bertieb Jul 20 '18 at 12:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    What have you tried? The very first entry when Googling this error code is exactly what you describe and there is an accepted solution. social.technet.microsoft.com/Forums/windows/en-US/… – acejavelin Jul 19 '18 at 17:26
  • Since you didn't indicate which build your Windows 10 installation is, I could only provide a generic solution, but the solution should still work. – Ramhound Jul 19 '18 at 17:39
2

The following should work.

  1. Mount the appropriate Windows 10 Enterprise ISO
  2. Open PowerShell as an Administrator
  3. Run the following commands:

Add-WindowsCapability -Online -Name NetFx3~~~~ Source D:\Sources\SxS

  1. Restart
  2. Done

Source: Error 0x800F0954 when installing .NET Framework 3.5

Not the answer you're looking for? Browse other questions tagged or ask your own question.