1

Not sure if I have malware or not, but I discovered this folder as I was working on my website:
enter image description here

Seems pretty normal, right? Well, when I tried to delete it, it was apparently symlinked to the actual "sergix.net" folder in the same directory. Ok, whatever, I'll just delete the symlink. But then it gave a message as if it was deleting the symlinked folder; strange. I backed up the real folder and deleted it from the directory. However, now when I try and delete whatever this crap is, it just says how the "sergix.net" I moved doesn't exist:
enter image description here

But in cmd, it reports as a directory:
enter image description here

And when I try to delete, it just says "not" found, most likely because the folder it's apparently linked to doesn't exist:
enter image description here

Also, rmdir on this folder removes it's symlinked folder when it exists.

It's also worth noting that it displays this as <DIR> and not <SYMLINK>.

So at this point, I've also tried Unlocker, rebooting, and a bunch of other things. I also don't know what made this file or anything; I did scan for malware but all it found was a small Trojan that has been deleted.

Also, ATTRIB reports it not finding the file.

Any advice?

  • 1
    Try dir /X to display the old DOS-formatted short names for files. In my testing, most of the commands just ignore the . at the end, so it is trying to delete sergix.net instead of sergix.net.. This Q&A may also be helpful. – Worthwelle Jul 19 '18 at 20:07
  • Ah, ok. It does display SERGIX~1, however when I attempt to delete it it still is symlinking to the other directory; neither del or rmdir seem to work still. – Sergix Jul 19 '18 at 20:47
  • It seems, for some odd reason, that of all things 7-Zip was able to at least move it, I found out after reading that Q&A. I'll see if I can delete it now. Thanks! – Sergix Jul 19 '18 at 20:52
1

I never considered it being that the folder name ended in a .; therefore, if you use 7-Zip or WinRar, you can pack it into a ZIP while selecting the option to delete the original folder. The only thing I'm still confused on is the Symlink aspect, but hey, it works.

Credit goes to @Worthwelle!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.