I am trying to re-install the OpenSSH Windows 10 feature on my computer, however the sshd service is failing to install. I have tried installing the feature both via the "optional features" and via the elevated Powershell command "Add-WindowsCapability -Online -Name OpenSSH.Server~~~~"".

I have searched for "sshd" in regedit in-case there was an orphan registry key preventing re-installation, but I did not find anything relevant. In addition, I tried Googling downloads for the service by itself, but could not find anything.

I used to have the Cygwin SSH server installed, and did delete the Cygwin SSH Server service as it share the same name with the Windows SSH Server service, however this did not resolve the issue.

Anyone have any ideas?


OpenSSH should not be added through the Add Feature page in Settings... I'm not sure why Microsoft has it in there, and can only surmise it was an oversight.

Remove OpenSSH that was installed via Add Features first, reboot, then install it via the instructions on the Win32-OpenSSH wiki on Microsoft's PowerShell GitHub.

  • YES!! This also worked for me. Here's an awesome article with clearly written steps: blog.techsnips.io/openssh-windows-setup – user24601 Aug 11 '18 at 16:35
  • 2
    @user24601 I would not recommend following any guide on any site, other than the explicit instructions on Microsoft's GitHub: Win32-OpenSSH's Wiki. Choosing to follow any other guide or wiki is simply asking for issues since Win32-OpenSSH is still in active development & its wiki instructions have changed several times as code has been changed. – JW0914 Aug 12 '18 at 13:19
  • Excellent point. I had found the TechSnips blog before seeing the Wiki. I may need to revise my answer on a related question or at least point to this answer. – user24601 Aug 12 '18 at 13:33
  • After going through a complete update from version 1709 to 1803 on a fresh install of Windows 10, I found that OpenSSH Client was automatically installed after the update to 1803. Furthermore, after the update to 1803 OpenSSH Server still needed to be added under Manage optional features -> Add a feature. More details here: superuser.com/a/1348488/384322 – user24601 Aug 12 '18 at 23:09
  • @user24601 OpenSSH client is not the same as OpenSSH server. The OpenSSH version installed via "Manage Optional Features" is an extremely old, obsolete version of OpenSSH (check the version)... there's a reason Microsoft has a Win32-OpenSSH wiki, and it should be followed, not disregarded. The optional feature's OpenSSH Server package should not be utilized... to understand why, please open an issue in the Win32-OpenSSH's repo on GitHub where the Win32-OpenSSH developers can explain why the GitHub version should be utilized over the version in Optional Features. – JW0914 Aug 14 '18 at 0:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.