0

I'm having an issue whereby none of the users on a machine can access the crontab. It used to be possible, but it seems to have recently stopped working after a backup was restored recently.

The error I'm getting is "You (...) are not allowed to access to (crontab) because of pam configuration.". I've looked up this issue and tried the steps here (add lines to give the users access to cron and crond, as well as a general line to grand all users access to all) but this did not work: https://support.oneidentity.com/authentication-services/kb/149615/user-unable-to-run-crontab-command-due-to-error-you-username-are-not-allowed-to-access-to-crontab-because-of-pam-configuration-

Thre is no password expiry. I'm not even sure if the user was set-up with a password. I have tried setting one up and it did not work anyway.

I was previously getting another error ("You (...) are not allowed to use this program (crontab)") but I was able to bypass this by creating an empty "cron.deny" file. I can't seem to be able to bypass this second error, I'm wondering if it could be a permissions issue?

I've tried logged-in as the user directly as well as logging in via "sudo -iu".

0

This issue was caused by some messed-up permissions on a number of files. Some of the relevant executable files were left with 777 permissions.

After restoring working permissions on these files based on another Centos 7 install, crontab started working again for all users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.