5

I have stuck with Firefox 52 ESR because I rely on some add-ons for which there aren't yet replacements in Quantum. I often spawn multiple tabs containing videos. These all start playing immediately in competition with each other, and I need to jump from tab to tab to pause each video, then go back and play each one individually. The problem has been fixed in Firefox Quantum, but still exists in the pre-Quantum versions.

Note that this issue is different from stopping auto-play (for which there are already a number of questions and answers). Auto-play is fine, I just don't want it to start until I switch to the tab.

For anyone else in this situation, I'll post an answer on how to solve this, although the thread's useful life will be limited because support will end for the pre-Quantum ESR version.

My issue is the opposite of this question, which refers to undoing the "corrected behavior" in post-Quantum versions. The applicable parameter is the same, but the solution route in that answer is different, and users with my problem may not find that reverse question in a search. So I'll post the route and setting that I know works in pre-Quantum Firefox.

5

This action is controlled by a setting in about:config.

  • Type about:config in the URL window.
  • You will get a warning about voiding the warranty. This is a tongue-in-cheek warning intended to alert you to the dangers of messing with these setting. Just accept the warning.
  • Scroll down through the settings to media.block-autoplay-until-in-foreground. The default setting is false.
  • Right-click the parameter and toggle it to True.
  • Close the about:config tab.

Source: https://support.mozilla.org/en-US/questions/1171104

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.