2

I have an Asus X555DA laptop that hadn't been booting. Unfortunately, I don't know exactly what caused this previous problem. In an attempt to fix it I tried to install Ubuntu. Although the installation completed successfully, it didn't boot into Ubuntu upon restart.

After going to the BIOS to see if something was wrong with my boot order, I found out that my hard drive wasn't listed in the Boot Option Priorities section. I don't believe the drive is bad because if I go to AdvancedSATA Configuration, the device shows up there, but only if the SATA Mode Selection is set to IDE.

After disabling secure boot (and keeping the SATA Mode set to IDE), what I assume is the Ubuntu installation (as the installation flash drive isn't plugged in and it is called ubuntu (PO: [Hard Drive Serial Number]) appears in the boot order. However, when I set it to the first slot of the Boot Option Priorities and restart, it boots straight to the BIOS instead of Ubuntu.

I opened up my computer and tried to manually reset the BIOS that way, but couldn't find the battery on the motherboard, even after some research.

I also updated the BIOS with no perceived effect (version 517 → 520).

I know very little about the software "underneath" the OS. Please share anything that could help with this situation.

  • X555XDA doesn't seem to exist. For the X555LA the latest BIOS is version 602 and the disk is definitely not IDE. You might reset the BIOS to defaults. Remark: In this post a similar problem was with the disk connectors, meaning hardware. – harrymc Jul 22 '18 at 6:42
  • @harrymc My bad; there was a typo in the model number for the laptop. I've edited my post to show the correct one. – dbK Jul 22 '18 at 7:17
  • You have the right BIOS. If resetting to defaults does not work, have the laptop repaired. – harrymc Jul 22 '18 at 8:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.