0

I've got two routers connected via ethernet on two different floors of my house, both with the same SSID, and identical security settings.

When connecting via ethernet to either router, all computers can see each other. E.g. basement-1 can ping secondfloor-1, and vice-versa.

When connecting via wi-fi, my Windows 10 machine, which is connected to the router on the second floor, cannot see any machines in the basement. This problem does not exist for other devices (e.g. OS X, iPad, or Android tablets).

Some additonal informaiton based on questions so far:

  • To test, I renamed the router on the second floor to a new SSID. This ensured I was not actually connected to the basement router
  • Network setup is as follows:
    • Basement Router: 192.168.13.2 (stock D-Link)
    • Second Floor Router: 192.168.13.8 (DDWRT)
    • Windows 10 machine: 192.168.13.116 (I have tried both static and DHCP IP - no difference)
    • NAS connected to basement router: 192.168.13.150
    • Printer connected to basement router: 192.168.13.50
    • Computer connected to basement router: 192.168.13.100
    • ROKU connected to second floor router via Ethernet: 192.168.13.106
  • Ping tests:
    • Win 10 on second floor router ping basement router via wi-fi: Fail
    • Win 10 on second floor router ping basement computer/printer/NAS via wi-fi: Fail
    • Win 10 on second floor router ping google.com via wi-fi: Success
    • Win 10 on second floor router ping basement router via ethernet: Success
    • Win 10 on second floor router ping basement computer/printer/NAS via ethernet: Success
    • Win 10 on second floor router ping ROKU via wi-fi: Success
    • Win 10 on second floor router ping google.com via ethernet: Success
    • iPad on second floor router ping basement computer: Success
    • iPad on second floor router ping basement router: Success
    • Computer on basement router ping Win 10 machine on second floor router via wifi: Fail

In a nutshell, it looks like the Windows 10 machine specifically cannot see anything connected to the basement router, but it can see the internet. It can also see devices connected to the second floor router (e.g. ROKU). Second floor items can also see basement items (iPad works okay via wifi; ROKU works via ethernet - both can access the NAS in the basement).

Output of route -4 print:

===========================================================================
Interface List
  5...54 e1 ad 71 de a7 ......Intel(R) Ethernet Connection (4) I219-V
 10...ae ed 5c b9 c0 67 ......Microsoft Wi-Fi Direct Virtual Adapter
 17...ac ed 5c b9 c0 68 ......Microsoft Wi-Fi Direct Virtual Adapter #2
 15...00 ff b0 04 2e e0 ......TAP-Windows Adapter V9
  8...ac ed 5c b9 c0 67 ......Intel(R) Dual Band Wireless-AC 8265
  9...ac ed 5c b9 c0 6b ......Bluetooth Device (Personal Area Network)
  1...........................Software Loopback Interface 1
===========================================================================

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0     192.168.13.1   192.168.13.116     50
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    331
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    331
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    331
     192.168.13.0    255.255.255.0         On-link    192.168.13.116    306
   192.168.13.116  255.255.255.255         On-link    192.168.13.116    306
   192.168.13.255  255.255.255.255         On-link    192.168.13.116    306
        224.0.0.0        240.0.0.0         On-link         127.0.0.1    331
        224.0.0.0        240.0.0.0         On-link    192.168.13.116    306
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    331
  255.255.255.255  255.255.255.255         On-link    192.168.13.116    306
===========================================================================
Persistent Routes:
  None

Any suggestions on what may be happening? I'm confident the router setups are okay because everything seems to work fine with other platforms; the problem seems to be specific to the Windows 10 machine on wifi.

Thanks.

UPDATE

It looks like there is something materially wrong with both routers in my house; the issues above seem to resolve if I do a full power-down (i.e. unplug), pause 1 minute, and then re-power everything, starting with the basement router, then the second floor router, and then re-enabling WiFi on all devices. Both routers are older models; as a next step I may try installing DD-WRT on the basement router and seeing if that fixes anything.

  • It may be your firewall. Try disabling it and ping again. – Sergio Dominguez Jul 22 '18 at 4:16
  • Thanks; thought of that, no firewall enabled. Even if it was: wouldn't the firewall have prevented ethernet pings from working? – tendim Jul 22 '18 at 4:18
  • Firewall on the router is meant more so for the the internet.In this intranet the local pc's anti-virus and firewall would prevent the pings from working. Disable firewall on the local pc. – Sergio Dominguez Jul 22 '18 at 4:22
  • Thanks. No firewall enabled, period. On router or PC. No anti-virus installed either. – tendim Jul 22 '18 at 4:25
  • 1
    After you pinged something in the basement what is the output of "arp -a"? This must be something on the DD-WRT. – bcs78 Jul 22 '18 at 17:07
0

I suspect your Win 10 box's WNIC is losing its ability to receive multicasts (including broadcasts), which breaks ARP, which keeps it from being able to address packets to devices that aren't in its ARP cache.

As a simple test of this hypothesis, add a static ARP mapping, in the Win 10 box, for one of the boxes it can't ping. If that allows it to ping that box, you know ARP was broken somehow.

Many WNICs are buggy when it comes to dealing with a separate cipher for multicasts/broadcasts than for unicasts, which is the case when original WPA (TKIP) is left enabled alongside WPA2 (AES-CCMP). So if you've left original WPA enabled on either of your routers, be sure to disable it so you're in pure WPA2-(AES-CCMP)-only mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.