2

I got a bricked UBNT EdgeRouter X router. It was bricked while changing the firmware using SSH. Then when I was trying to unbrick it using UART - the 3v3 router pin was connected to 3v3 UART.

Now router's 3v3 pin is giving 0.0 voltage. But router's LEDs are still working in case I power on or connect and disconnect patch cords.

I tried to connected it using

  • TXD↔RX, RXD↔TX, GND↔GND
  • and TXD↔TX, RXD↔RX, GND↔GND.

I used PuTTY, tried to connect using the COM number that I get from Computer>Manage>Device Manager. Baud rate 115200, Data Bits 8, Stop Bits 1, Flow Control None.

And in both cases I get blank PuTTY window.

Is there a way to fix it? If I give router to a service center they will be able to fix it?

8
  • 2
    Voted to close because there are lots of routers and lots of meaning of the word brick with respect of them.
    – davidgo
    Jul 22, 2018 at 8:39
  • 1
    "Bricked" can mean so many things... in many cases, it's unlikely you'll be able to fix it via a UART alone... Especially if a test point marked 3.3v is reading 0v - that could well be a hardware issue.
    – Attie
    Jul 22, 2018 at 8:40
  • @KamilMaciorowski UBNT EdgeRouter X
    – user926368
    Jul 22, 2018 at 9:17
  • 1
    You can (should) add relevant information by editing the question. This time I did it for you. You may write a comment to notify the user who asked for clarification (as you did), but the question itself should be standalone and not rely on comments that follow. Jul 22, 2018 at 9:32
  • 1
    Usually cure of bricked devices is done via JTAG connector (not UART), but AFAIK Ubiquiti dosen't support it well. IMHO the best way is to bring it to service center
    – Alex
    Jul 22, 2018 at 12:37

1 Answer 1

0

You didn't say exactly what you did via ssh that "bricked the firmware".

Most routers have different parts for the firmware. The first stage is a comparatively simple, often uboot. This first-stage then loads the real firmware as second stage. Googling seems to confirm that UBNT EdgeRouter X uses uboot.

So if you didn't destroy uboot by whatever you were doing, you should be able to use the uboot recovery mode (google).

If you did destroy it, there's probably nothing you can do. The lessen to learn then is that when doing a firmware upgrade, you always upgrade the "proper" (second-stage) firmware only. And before you do it, you have a good look at what part of the flash ROM contains which kind of information.

Edit

As there seems to be some confusion about this, let's sort out serial/UART vs. JTAG.

Looking at the OpenWRT page for the router, one can see the UART/serial connection in the following picture:

UART/serial port

This will provide a serial console to the device, which needs a working firmware, e.g. uboot. If uboot is already running anyway, there's no advantage in using the serial console over using the network console in recovery mode (unless this doesn't work for some reason). And the network console doesn't need additional hardware, like the wires one needs to connect to the serial port.

The chipset also seems to have a JTAG port, though I haven't found any indication where it is on the board. The standard JTAG header has 20 pins, in the picture one can see room for a header (not soldered) with 14 pins, which may contain some of the JTAG pins (or may be something completely different). There also may be no unsoldered JTAG header at all, and it would be necessary to get the JTAG signals directly from the main chipset.

With JTAG, it's possible to also flash the first-stage bootloader, but to do that, one needs special hardware that understand the JTAG protocol. A simple serial connection won't do.

When having the choice between buying JTAG-protocol hardware, and buying a new router, buying a new router usually is cheaper. Unless one plans to do a lot of hacking in the future using JTAG.

7
  • 1
    Even fully bricked you can get the bootloader back on via jtaging. (Which is what he is trying to do) this isn't really an answer to the question. Jul 22, 2018 at 16:00
  • @Tim_Stewart: If I understood what the OP wrote correctly, he is not doing JTAG-firmware reprogramming, he is using the serial port (UART). This will give him a serial console, which again will require a working uboot. JTAG needs a different protocol, and he needs to have hardware that speaks JTAG, and he needs to identify the JTAG pins (which may have a header or not; UART headers are much more common). If he can do that, he should edit the question... but then he probably wouldn't need to ask how to do it.
    – dirkt
    Jul 23, 2018 at 5:57
  • I figured he was mixing the terms. I believe it's a TTL board to reprogram these. Jul 23, 2018 at 6:17
  • @Tim_Stewart: Sorry, I don't follow you. What do you mean by "TTL board"? You mean JTAG protocol hardware with a serial interface? I see nothing in the original post that mentions anything about JTAG... All I see is serial. And routers do have an UART, and the uboot firmware does have a repogramming via UART capability - but you need working uboot for this. In which case it would be simpler to unbrick via recovery mode/TFTP (no extra hardware needed).
    – dirkt
    Jul 23, 2018 at 6:45
  • TTL = transistor to transistor logic. It's signaling is usually either +3.3v or +5v. If he hooked it up with a regular rs-232 it's voltage would burn out the chip, it has a way higher voltage. sparkfun.com/tutorials/215 you need a TTL adapter on most boards that interface directly with a microcontroller/SoC. adafruit.com/product/70 Jul 23, 2018 at 16:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .