4

When I use my touchpad to scroll on chrome and switch/open tabs, the "scrolling motion/input" carries over to the next tab, and since I am pressing Ctrl to open/switch to a tab, it zooms in the next page. My fingers have already stopped scrolling by the time I change tabs (but the original screen is still "scrolling").

I usually don't carry around a mouse, and I rely on using just my touchpad for my laptop, so this issue is quite annoying. Is there a fix/extension that resolves this? If there is no specific fix for this, I am happy with just disabling ctrl+touchpad-scroll zooming all together - I never use this functionality.

I'm on an ASUS GL502VM.

0

My fingers have already stopped scrolling by the time I change tabs (but the original screen is still "scrolling").

The problem is that this "inertial scrolling" isn't done by Chrome, but instead by your touchpad driver. That is, the driver emulates inertial scrolling by continuing to send fake "mouse scroll" events after you release the touchpad. Programs like Chrome cannot distinguish these scroll events from "real" ones.

(Perhaps Windows 10 "Precision Touchpad" mode is supposed to fix this? Though still it would only help with modern touchpad-aware programs.)

I would suggest disabling inertial scrolling globally in your touchpad's settings.

There is no option to disable Ctrl+scroll zooming in Chrome, but see older threads – some of them describe how to set up AutoHotKey to block Ctrl+scroll events system-wide:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.