0

I'm trying to install orca on Windows using these instructions. I'm not sure I understand point 4:

  • In the command prompt, run PATH %PATH%;<paste the "Starts in" field here>

In the prompt, I wrote the copied path as

  • PATH %PATH%; C:\Users\my_pc\AppData\Local\Programs\orca\orca.exe

I also tried

  • PATH %PATH% C:\Users\my_pc\AppData\Local\Programs\orca\orca.exe

I even restarted PC. Nothing happened. E.g., When I write orca --help the answer is:

enter image description here

Question: Is there a syntax error in my code? How can I get orca installed correctly?

1

Not sure what orca is but from the looks of it all you're trying to do is add the executable to your PATH environment variable. Basically what that does is just adds the full location to your program so you don't have to specify the full location when running commands.

NOTE Only the location of the program has to be added to the PATH. That means you need to exclude the name of the executable itself.

Few things you can do to check it. From command prompt echo out your full path and check if the path to your orca exe is there - echo %PATH%

To set the path from CMD I think you need to use set set PATH=%PATH%;C:\Users\my_pc\AppData\Local\Programs\orca\ It basically means set the path variable to whatever it currently is plus this new thing. Which is what you would want, you almost definitely don't want to override the full path.

For UI version you can open System Properties menu and 'Environment variables' option should be at the bottom. Hit 'Path' variable and select edit and double check if it's there. If not you can add it from here.

Finally to rule out issue with your commands/program - try passing the full location to the command. i.e C:\Users\my_pc\AppData\Local\Programs\orca\orca.exe --help

Let me know how you get on.

| improve this answer | |
  • I added C:\Users\my_pc\AppData\Local\Programs\orca\orca.exe to the path manually. Writing C:\Users\my_pc\AppData\Local\Programs\orca\orca.exe works. But orca doesn't. By writing PATH I see that the last element is the path to orca.exe – GegznaV Jul 23 '18 at 12:32
  • Sorry my mistake. Try adding only the url up to the folder containing the exe to your PATH. i.e. `C:\Users\my_pc\AppData\Local\Programs\orca` - Close down the command prompt and open a new one. Changes to PATH apply only to new sessions of cmd. – Gytis Jul 23 '18 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.