0

I'm trying to Remote Desktop to another Windows PC. Both computers are in the same WORKGROUP. I can ping the remote computer by its hostname, which responds with its IPv4 address. I could get that work after running Prefer IPv4 over IPv6 in prefix policies EasyFix from Microsoft. Before running the EasyFix, pinging remote host responded with IPv6.

I can also connect with Remote Desktop Connection using IPv4 and it works, however, trying to Remote Desktop with hostname gives me this error:

Remote Desktop can't find the computer "OTHERWINPC". This might mean that "OTHERWINPC" does not belong to the specified network. Verify the computer name and domain that you are trying to connect to.

What can be the issue?

4
  • Guess: The remote computer also has an IPv6 address, and that IPv6 address isn't reachable? And remote desktop prefers IPv6 over IPv4, even with the prefix policy? – dirkt Jul 24 '18 at 6:54
  • @dirkt That's correct. Remote computer is not reachable by IPv6, and apparently RDP prefers IPv6 over IPv4. – orad Jul 24 '18 at 7:23
  • So the simplest fix would be to make it look like the remote computer only has an IPv4 address, for example by using a slightly different name, and entering it in the hosts file (if it has a static address). Or any other solution depending on how you've setup your local DNS. – dirkt Jul 24 '18 at 8:11
  • Or fix whatever problem has broken IPv6 connectivity. – Michael Hampton Jul 24 '18 at 13:59
1

Answering myself: The fix was something really weird. First I made sure that both local computer and remote computer prefer IPv6 over IPv4 using the EasyFix. Then I noticed I could not ping the remote computer when I use all caps for hostname. I got:

Ping request could not find host MYHOME-PC. Please check the name and try again.

but could ping with any other casing like ping myhome-pc or ping MyHome-PC that came back with IPv6. I used all lowercase hostname to connect with remote desktop and that worked!

1
  • 2
    That's a little strange. Hostnames are not case sensitive. So it shouldn't matter if you have caps lock on or not. I wonder what's going on there. – Michael Hampton Aug 4 '18 at 13:44
0

In your situation, when you used RDP the hostname, it should have returned the ipv6 address, so that you RDP failed.

You can use this workaround, add a CNAME(alias) DNS record of the ipv4 for the target PC in the DNS server. And then use the CNAME to RDP the target PC.

0

Try adding "\\" to the beginning of the computer name

For your "OTHERWINPC" example, try "\\OTHERWINPC" instead.

At least this is what worked for me. I only started encountering this error earlier this year. In light of the other comments here, perhaps it was due to some sort of IPv6 change in some upgrade. And maybe "\\" ends up forcing IPv4.

-1

Disabling IPv6 on this server 2012 box fixed the issue for me. Thanks.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.