1

I am trying to communicate via IPv6 between a Windows 10 machine and a Redhat 7.5 Linux machine. I am testing my connection by trying to ping both machines from each other's terminal.

I can ping both of my Linux machine's IPv4 and IPv6 addresses from my Windows machine through the command line. However, I cannot ping either of my Windows machine's IPv4 or IPv6 addresses from my Linux machine through the terminal.

That is:

When I type ping6 in my Linux terminal, it cannot reach the Windows machine. All packets are lost.

When I type ping in my Linux terminal, it cannot reach the Windows machine. All packets are lost

I was able to connect two Windows 10 machines together with the same crossover cable and they could both ping and ping -6 each other just fine, so I do not believe it is a firewall issue.

I believe it is something wrong with my Linux machine, since I have not tested IPv4 or IPv6 with it through the terminal. Note that my Linux machine can connect to the internet just fine.

Network Information:

Windows IPv4 address: 111.111.111.111

Linux IPv4 address: 111.111.111.112

Subnet mask: 255.255.255.0

Windows IPv6 address: fe80::9509:5d34:26b2:3a8c

Linux IPv6 address: fe80::9509:5d34:26b2:3a8d

Subnet mask prefix: 64

Both machines are connected directly via a Crossover Ethernet cable. There is no box or anything in between them.

Is there anything that I can do/check to get my Linux machine to be able to ping my Windows machine's IPv6 address.

  • 3
    On the Windows machine reply to ping can be disabled. Check firewall settings. – ddbug Jul 24 '18 at 15:48
  • 3
    Every time I see this it's the Windows firewall. Disable ping is on by default on some versions. – HackSlash Jul 24 '18 at 15:50
  • On top of the firewall comments, this seems to be the default behavior for networks marked as 'Public' (which is now the default for all networks in consumer versions of Windows). Check if the network is public or not, and if so, switch it to private and see if that helps. – Austin Hemmelgarn Jul 25 '18 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.