I am running Mac 10.13.6 High Sierra and my friend accidentally changed the Open With option for the Downloads folder to TextEdit and now if I double click on the Downloads icon from Macintosh HD, it opens up the TextEdit app with bunch of random characters.

I can still get to my Downloads folder via the left task pane but I just want to get it fixed. It is annoying to see a folder which usually has a blue thumbnail turn into a white icon sitting there.


After running ls -leO@, I get this output:

Sadmans-MacBook-Pro:~ jiltedpotion$ ls -leO@ total 0 drwxr-xr-x 2 jiltedpotion staff - 64 Apr 25 01:39 AnacondaProjects drwxr-xr-x 3 jiltedpotion staff - 96 Jul 24 03:09 AndroidStudioProjects drwx------@ 3 jiltedpotion staff - 96 Apr 5 06:21 Applications com.apple.quarantine 21 drwxrwxr-x@ 5 jiltedpotion staff - 160 Jun 21 21:14 Creative Cloud Files com.apple.FinderInfo 32 drwx------+ 8 jiltedpotion staff - 256 Jul 25 05:33 Desktop 0: group:everyone deny delete drwx------+ 19 jiltedpotion staff - 608 Jul 13 04:28 Documents 0: group:everyone deny delete drwx------+ 19 jiltedpotion staff - 608 Jul 25 18:18 Downloads 0: group:everyone deny delete drwx------@ 72 jiltedpotion staff hidden 2304 May 3 16:54 Library com.apple.FinderInfo 32 0: group:everyone deny delete drwx------+ 16 jiltedpotion staff - 512 Jul 25 05:02 Movies 0: group:everyone deny delete drwx------+ 9 jiltedpotion staff - 288 Apr 11 21:11 Music 0: group:everyone deny delete drwx------+ 46 jiltedpotion staff - 1472 Jul 14 03:27 Pictures 0: group:everyone deny delete drwxr-xr-x 7 jiltedpotion admin - 224 May 21 09:07 PromotionRes drwxr-xr-x+ 4 jiltedpotion staff - 128 Apr 2 22:05 Public 0: group:everyone deny delete drwx------ 4 jiltedpotion staff - 128 Jul 25 05:02 VirtualBox VMs drwxr-xr-x 3 jiltedpotion staff - 96 Apr 5 03:01 YoutubeDL

When I click on Downloads in the Finder's sidebar, it takes me in the downloads folder without any problem. The problem begins if I try to go from Macintosh HD.

  • If someone wants further clarification, you could check out the situation here: imgur.com/a/nZjJ2QQ – jiltedpotato Jul 24 '18 at 22:42
  • 1
    I'm pretty sure something weirder than an "Open With" change has happened, but I'm not sure what. Can you open the Terminal utility, run the command "ls -leO@" (note: the "l" characters are lowercase letter L's, and the "O" is a capital letter O rather than zero). Then edit the output into your question, in code format (so it's readable). Also, what happens when you click the Downloads icon in the Finder's sidebar? – Gordon Davisson Jul 25 '18 at 3:38
  • I'm with @GordonDavisson on this one. You don't get an 'open with' option on a folder, ever... unless something, somewhere, went badly wrong already. – Tetsujin Jul 25 '18 at 6:18
  • I wonder if this is one of those rare situations where manually fixing permissions might actually fix the issue: sudo diskutil repairPermissions / – Steve Chambers Jul 29 '18 at 22:17

I don't know anything about Mac but my first instinct would be to revert what he did by changing the open with... back to it's default setting. Or you could try using a restore point to undo it if you so happen to conveniently have one. Again, i have no idea how Macs work, never owned one and i never plan to either.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.