12

I'm using a conference application called Zoom. There are URLs that can be clicked to open the application and let jump in right away to the meeting that ID existed in the URL. For example: https://zoom.us/j/1234567890

But none of the URLs I tried actually opens the application.

Or for instance when I try to login to my account, the app opens Firefox which after logging in through the web, redirects me to zoommtg://zoom.us/google?code=XXX and Firefox shows a message saying "The address wasn’t understood".

I tried the following boolean key on the about:config page for Firefox.

network.protocol-handler.expose.zoommtg=false

and I tried assigning true instead of false, but this didn't do the trick.

My Firefox has the following key/value

network.protocol-handler.expose-all;true

I understand that this configuration makes me not need to set the previous one as it overrides it.

From within my ~/.local/share/applications

$ cat Zoom.desktop 
[Desktop Entry]
Name=Zoom
Comment=Zoom Video Conference
Exec=/usr/bin/zoom %U
Icon=Zoom.png
Terminal=false
Type=Application
Encoding=UTF-8
Categories=Network;Application;
StartupWMClass=zoom
MimeType=x-scheme-handler/zoommtg;application/x-zoom;
X-KDE-Protocols=zoommtg
Name[en_US]=Zoom
$ cat mimeapps.list 

[Default Applications]
text/html=firefox_firefox.desktop
x-scheme-handler/http=firefox_firefox.desktop
x-scheme-handler/https=firefox_firefox.desktop
x-scheme-handler/about=firefox_firefox.desktop
x-scheme-handler/unknown=firefox_firefox.desktop
x-scheme-handler/zoommtg=Zoom.desktop
application/x-zoom=Zoom.desktop

How can I configure Firefox to redirect the Zoom URLs to the application, so I can login to my account and use meeting links to join the meetings instantly ?

5 Answers 5

14

I struggled with this as the instructions on adding a new protocol either referred to pre-Quantum versions of Firefox or assume I have gnome. Finally what worked for me were the instructions I found here: https://www.reddit.com/r/firefox/comments/6p6470/firefox_doesnt_recognize_telegramdesktops_tg_link/

  1. Type about:config in the location bar to get to Firefox configuration. Right click -> New -> Boolean -> "network.protocol-handler.expose.zoommtg" -> false
  2. (Likely superfluous, but I did this while looking for the solution so I'm including it.) Still in about:config, Right click -> New -> Boolean -> "network.protocol-handler.external.zoommtg" -> true
  3. Copy the zoommtg://zoom.us/... link Firefox couldn't open. Then type the following in the location bar: data:text/html,<a href="[PASTE ZOOMMTG LINK HERE]">Click me</a>
  4. An empty webpage should show up with a link that says "Click me" in the top left corner. Click it :D
  5. Firefox should pop up a dialog asking you for the application to open the protocol. Provide the path to the zoom application (if you don't know where it is, type which zoom in a terminal).

Hope it works. Good luck!

2
  • Confirming this still works with Firefox 80 on Ubuntu Linux. Oct 2, 2020 at 0:46
  • For me the key step is step 2: "network.protocol-handlers.external.zoommtg: true". I didn't need any other about:config entries, and I didn't need a desktop shortcut. I'm on Firefox 94.0 and Void Linux.
    – dpercy
    Dec 22, 2021 at 6:22
2

Change your default web browser to Internet Explorer (or another one) to see if it works to isolate if its an issue with Windows or the browser. If its an issue in Windows, in Win10 Settings, System, Default apps, Choose default apps by protocol (or '...by file type). I use Zoom with Firefox v61.0.2 & Win10, here is some pics to maybe help. All else fails reinstall Zoom and/or Firefox. enter image description here enter image description here enter image description here

1

Mine stopped working when I upgraded zoom. My fix was to go to about:preferences and change the action from "Use Zoom" to "Use other..." and selected /usr/bin/zoom.

firefox applications action

1

Although this is an old thread I wanted to share my findings as the issue might still occur.

Unfortunately previous solutions didn't seem to work in my case (Firefox 95.0, Arch Linux). Therefore I tried to manually add an entry to the applications list of the settings (in addition to setting network.protocol-handler.external.zoommtg as true as described by others):

  1. Find your handlers.json in ~/.mozilla/firefox/*/. (I found it by searching for an URI scheme that already was present in settings: grep -rnw ~/.mozilla/firefox/ -e mailto)
  2. Add an entry for zoommtg inside the schemes object (next to mailto for example), eg.: "zoommtg":{"stubEntry":true,"handlers":[null]} (right before the last trailing brackets }}).
  3. Start/Restart Firefox.
  4. Look for the corresponding entry under Settings >> General >> Applications
  5. Select the Zoom app. (If it is not shown by default, you will need to add the application (eg. /usr/bin/zoom).)
  6. Zoom links should be opened in Zoom now.

Additionally, reinstalling Firefox could also solve the issue (especially if Firefox was initially installed before Zoom).

1
  • 1
    Add zoommtg to handlers.json (2.) and select the zoom executable (4.) worked on firefox at xubuntu 20.04, thank you! Final generated entry with path:"zoommtg":{"handlers":[{"name":"ZoomLauncher","path":"/path/to/ZoomLauncher"}],"action":2}
    – 2IRN
    Jan 18 at 18:20
0

I had the same problem on Gentoo Linux

  1. I added the network.protocol-handler.external.zoommtg setting with true value
  2. Then in about:preferences > General > Applications, I associated zoommtg with ZoomLauncher

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.